summaryrefslogtreecommitdiffstats
path: root/test/unit/ui/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2013-03-27 23:48:44 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2013-03-27 23:48:49 +0100
commit212f2e41f88a85ad7f47bc526b79fae2b4952d3a (patch)
tree81e8b660bfe6bb8cf0f55932767f826ab9b080dc /test/unit/ui/CMakeLists.txt
parent8659fb984f4fe5495d5a3ddbeeb7bd592f0c4a4c (diff)
downloadcolobot-212f2e41f88a85ad7f47bc526b79fae2b4952d3a.tar.gz
colobot-212f2e41f88a85ad7f47bc526b79fae2b4952d3a.tar.bz2
colobot-212f2e41f88a85ad7f47bc526b79fae2b4952d3a.zip
Fixed edit_test
Diffstat (limited to 'test/unit/ui/CMakeLists.txt')
-rw-r--r--test/unit/ui/CMakeLists.txt54
1 files changed, 32 insertions, 22 deletions
diff --git a/test/unit/ui/CMakeLists.txt b/test/unit/ui/CMakeLists.txt
index b0d9ce2..c899834 100644
--- a/test/unit/ui/CMakeLists.txt
+++ b/test/unit/ui/CMakeLists.txt
@@ -7,25 +7,35 @@ ${GTEST_INCLUDE_DIR}
${GMOCK_INCLUDE_DIR}
)
-# add_executable(edit_test
-# ${SRC_DIR}/common/event.cpp
-# ${SRC_DIR}/common/logger.cpp
-# ${SRC_DIR}/common/misc.cpp
-# ${SRC_DIR}/common/profile.cpp
-# ${SRC_DIR}/common/iman.cpp
-# ${SRC_DIR}/common/stringutils.cpp
-# ${SRC_DIR}/graphics/engine/text.cpp
-# ${SRC_DIR}/ui/button.cpp
-# ${SRC_DIR}/ui/control.cpp
-# ${SRC_DIR}/ui/edit.cpp
-# ${SRC_DIR}/ui/scroll.cpp
-# stubs/app_stub.cpp
-# stubs/engine_stub.cpp
-# stubs/particle_stub.cpp
-# stubs/restext_stub.cpp
-# stubs/robotmain_stub.cpp
-# edit_test.cpp)
-# target_link_libraries(edit_test gtest gmock ${SDL_LIBRARY} ${SDLTTF_LIBRARY} ${Boost_LIBRARIES})
-#
-# TODO: Edit test doesn't work, comment it away for now
-# add_test(edit_test ./edit_test)
+# Platform-dependent implementation of CSystemUtils
+if (${PLATFORM_WINDOWS})
+ set(SYSTEM_CPP_MODULE "system_windows.cpp")
+elseif(${PLATFORM_LINUX})
+ set(SYSTEM_CPP_MODULE "system_linux.cpp")
+else()
+ set(SYSTEM_CPP_MODULE "system_other.cpp")
+endif()
+
+add_executable(edit_test
+${SRC_DIR}/app/system.cpp
+${SRC_DIR}/app/${SYSTEM_CPP_MODULE}
+${SRC_DIR}/common/event.cpp
+${SRC_DIR}/common/logger.cpp
+${SRC_DIR}/common/misc.cpp
+${SRC_DIR}/common/profile.cpp
+${SRC_DIR}/common/iman.cpp
+${SRC_DIR}/common/stringutils.cpp
+${SRC_DIR}/graphics/engine/text.cpp
+${SRC_DIR}/ui/button.cpp
+${SRC_DIR}/ui/control.cpp
+${SRC_DIR}/ui/edit.cpp
+${SRC_DIR}/ui/scroll.cpp
+stubs/app_stub.cpp
+stubs/engine_stub.cpp
+stubs/particle_stub.cpp
+stubs/restext_stub.cpp
+stubs/robotmain_stub.cpp
+edit_test.cpp)
+target_link_libraries(edit_test gtest gmock ${SDL_LIBRARY} ${SDLTTF_LIBRARY} ${Boost_LIBRARIES})
+
+add_test(edit_test ./edit_test)