summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..02016af
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,14 @@
+# CMake project file for compiling with MinGW
+
+cmake_minimum_required(VERSION 2.8)
+
+project(colobot CXX)
+
+set(CMAKE_BUILD_TYPE debug)
+
+# Currently compiles only with -fpermissive
+
+set(CMAKE_CXX_FLAGS_RELEASE "-fpermissive -O2")
+set(CMAKE_CXX_FLAGS_DEBUG "-fpermissive -w -g -O0")
+
+add_subdirectory(src bin)