summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 2bd7461..78a63b7 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -6,10 +6,12 @@ find_program(XGETTEXT_CMD xgettext)
add_custom_command(OUTPUT ${_potFile}
COMMAND ${XGETTEXT_CMD} ${colobot_SOURCE_DIR}/src/app/app.cpp --output=${_potFile}
- COMMAND ${XGETTEXT_CMD} ${colobot_SOURCE_DIR}/src/common/restext.cpp --output=${_potFile} --join-existing --extract-all --no-location
+ COMMAND ${XGETTEXT_CMD} ${colobot_SOURCE_DIR}/src/common/restext.cpp --output=${_potFile} --join-existing --keyword=TR --no-location
+ COMMAND sed -i -E "s|^(\"POT-Creation-Date:).*$|\\1 DATE\\\\n\"|" ${_potFile}
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
COMMENT "Extract translatable messages to ${_potFile}"
+ VERBATIM
)
add_custom_target(update-pot DEPENDS ${_potFile})
@@ -17,4 +19,3 @@ add_custom_target(update-pot DEPENDS ${_potFile})
file(GLOB _poFiles *.po)
set(GETTEXT_INSTALL_PREFIX ${COLOBOT_INSTALL_I18N_DIR})
gettext_create_translations(${_potFile} ALL ${_poFiles})
-