summaryrefslogtreecommitdiffstats
path: root/src/CBot/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CBot/CMakeLists.txt')
-rw-r--r--src/CBot/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/CBot/CMakeLists.txt b/src/CBot/CMakeLists.txt
new file mode 100644
index 0000000..409ef3b
--- /dev/null
+++ b/src/CBot/CMakeLists.txt
@@ -0,0 +1,15 @@
+set(SOURCES
+CBot.cpp
+CBotClass.cpp
+CBotFunction.cpp
+CBotIf.cpp
+CBotProgram.cpp
+CBotStack.cpp
+CBotString.cpp
+CBotToken.cpp
+CBotTwoOpExpr.cpp
+CBotVar.cpp
+CBotWhile.cpp
+)
+
+add_library(CBot SHARED ${SOURCES})