summaryrefslogtreecommitdiffstats
path: root/src/CBot/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CBot/CMakeLists.txt')
-rw-r--r--src/CBot/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/CBot/CMakeLists.txt b/src/CBot/CMakeLists.txt
index 409ef3b..9f5b987 100644
--- a/src/CBot/CMakeLists.txt
+++ b/src/CBot/CMakeLists.txt
@@ -12,4 +12,8 @@ CBotVar.cpp
CBotWhile.cpp
)
-add_library(CBot SHARED ${SOURCES})
+if(${CBOT_STATIC})
+ add_library(CBot STATIC ${SOURCES})
+else()
+ add_library(CBot SHARED ${SOURCES})
+endif()