summaryrefslogtreecommitdiffstats
path: root/src/CBot/tests/CBot_console/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CBot/tests/CBot_console/CMakeLists.txt')
-rw-r--r--src/CBot/tests/CBot_console/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CBot/tests/CBot_console/CMakeLists.txt b/src/CBot/tests/CBot_console/CMakeLists.txt
index 7d9f034..3ba118d 100644
--- a/src/CBot/tests/CBot_console/CMakeLists.txt
+++ b/src/CBot/tests/CBot_console/CMakeLists.txt
@@ -3,7 +3,9 @@ cmake_minimum_required(VERSION 2.8)
project(CBot_console C CXX)
# Build with debugging symbols
-set(CMAKE_BUILD_TYPE debug)
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE debug)
+endif(NOT CMAKE_BUILD_TYPE)
# Global compile flags
set(CMAKE_CXX_FLAGS_RELEASE "-O2 -Wall -Wold-style-cast -std=gnu++0x")