summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2018-10-29 16:46:49 +0100
committerAlexander Sulfrian <alexander@sulfrian.net>2018-10-29 16:57:09 +0100
commitd4694f1c41c8770f6a6dd8ef18dd200a777e4bdd (patch)
treec1650854b5ef8fcbbd20349852cab99eb9b0dc45
parent1c08a83a375c901709f50d519bb17e6a1368eae1 (diff)
downloadbot-debian.tar.gz
bot-debian.tar.bz2
bot-debian.zip
phenny.init: Fix init script for stretchdebian
--chuid with a colon but without a group name is a fatal error for dpkg >= 1.18.3 [1]. dpkg changed from 1.17.27 to 1.18.25 with the update to stretch. 1: https://github.com/endlessm/dpkg/commit/3db7a6eb4fd16b4cea475009bd80be3a41ada014
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/phenny.init8
2 files changed, 13 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index d6703c9..1c4f955 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+phenny (1:2~git-2016-05-10~cd524df-2) unstable; urgency=medium
+
+ * phenny.init: Fix init script for stretch
+
+ -- Alexander Sulfrian <alex@spline.inf.fu-berlin.de> Mon, 29 Oct 2018 16:49:40 +0100
+
phenny (1:2~git-2016-05-10~cd524df-1) unstable; urgency=low
* Fix indentation and trailing whitespaces
diff --git a/debian/phenny.init b/debian/phenny.init
index 5dec77e..e0a87fe 100755
--- a/debian/phenny.init
+++ b/debian/phenny.init
@@ -48,11 +48,17 @@ chown "$PHENNY_USER:$PHENNY_GROUP" "$PIDDIR"
case "$1" in
start)
+ if [ -n "$PHENNY_GROUP" ]; then
+ CHUID="$PHENNY_USER:$PHENNY_GROUP"
+ else
+ CHUID="$PHENNY_USER"
+ fi
+
log_daemon_msg "Starting $DESC" "$NAME"
start-stop-daemon --start \
--pidfile "$PIDDIR/$NAME.pid" \
--make-pidfile \
- --chuid "$PHENNY_USER:$PHENNY_GROUP" \
+ --chuid "$CHUID" \
--background \
--exec $DAEMON -- --config "$PHENNY_CONFIG" $PHENNY_OPTS
log_end_msg $?