summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEvgeny Fadeev <evgeny.fadeev@gmail.com>2011-08-16 19:36:17 +0700
committerEvgeny Fadeev <evgeny.fadeev@gmail.com>2011-08-16 19:36:17 +0700
commit04e47ead3cdd67c221037c99b2e9222455feacb2 (patch)
treed3faed53b088ea53d2d1a4ead7e2c81181feb4a4 /setup.py
parentefd471d2a6963ee3528e4427624fda4cc3aaad71 (diff)
downloadaskbot-04e47ead3cdd67c221037c99b2e9222455feacb2.tar.gz
askbot-04e47ead3cdd67c221037c99b2e9222455feacb2.tar.bz2
askbot-04e47ead3cdd67c221037c99b2e9222455feacb2.zip
removed mysql dependency from setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py31
1 files changed, 10 insertions, 21 deletions
diff --git a/setup.py b/setup.py
index 331d3fb1..d319d761 100644
--- a/setup.py
+++ b/setup.py
@@ -26,14 +26,6 @@ install_requires = [
'python-openid',
]
-#todo: have a dirty version retriever that
-#parses it out from askbot/__init__.py but does not
-#import it as there are issues
-
-WIN_PLATFORMS = ('win32', 'cygwin',)
-if sys.platform not in WIN_PLATFORMS:
- install_requires.append('mysql-python')
-
import askbot
setup(
@@ -147,16 +139,13 @@ Footnotes
(**) - With MySQL you have to use MyISAM data backend, because it's the only one that supports Full Text Search."""
)
-if 'WIN_PLATFORM' in locals() and sys.platform in WIN_PLATFORMS:
- print 'ATTENTION!! please install windows binary mysql-python package'
- print 'at http://www.codegood.com/archives/4'
-
-print '**************************************************************'
-print '* *'
-print '* Thanks for installing Askbot. *'
-print '* To start deploying type: >python askbot-setup *'
-print '* Please take a look at the manual askbot/doc/INSTALL *'
-print '* And please do not hesitate to ask your questions at *'
-print '* at http://askbot.org *'
-print '* *'
-print '**************************************************************'
+print """**************************************************************
+* *
+* Thanks for installing Askbot. *
+* *
+* To start deploying type: >askbot-setup *
+* Please take a look at the manual askbot/doc/INSTALL *
+* And please do not hesitate to ask your questions at *
+* at http://askbot.org *
+* *
+**************************************************************"""