summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEvgeny Fadeev <evgeny.fadeev@gmail.com>2010-06-15 20:23:18 -0400
committerEvgeny Fadeev <evgeny.fadeev@gmail.com>2010-06-15 20:23:18 -0400
commit4e5a03a529e1e216aad971fb34be4871e02b1a5f (patch)
tree6367f2e8731d2760b96bf1cbc18cf5ce968c7d8b /setup.py
parent1e726b4251ca21b2f14e10332ab3b7dede57db8e (diff)
parentc0c7dbcfe24a7f2d8b4d16d122e278d079c297c6 (diff)
downloadaskbot-4e5a03a529e1e216aad971fb34be4871e02b1a5f.tar.gz
askbot-4e5a03a529e1e216aad971fb34be4871e02b1a5f.tar.bz2
askbot-4e5a03a529e1e216aad971fb34be4871e02b1a5f.zip
merged with branch experimental
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py77
1 files changed, 77 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..565eb190
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,77 @@
+import ez_setup
+ez_setup.use_setuptools()
+from setuptools import setup, find_packages
+import sys
+
+install_requires = [
+ 'django==1.1.2',
+ 'django-debug-toolbar==0.7.0',
+ 'South>=0.7.1',
+ 'recaptcha-client',
+ 'markdown2',
+ 'html5lib',
+ 'python-openid',
+ 'django-keyedcache',
+ 'django-threaded-multihost',
+]
+WIN_PLATFORMS = ('win32', 'cygwin',)
+if sys.platform not in WIN_PLATFORMS:
+ install_requires.append('mysql-python')
+
+setup(
+ name = "askbot",
+ version = "0.6.1",
+ description = 'Question and Answer forum, like StackOverflow, written in python and Django',
+ packages = find_packages(),
+ author = 'Evgeny.Fadeev',
+ author_email = 'evgeny.fadeev@gmail.com',
+ license = 'GPLv3',
+ keywords = 'forum, community, wiki, Q&A',
+ entry_points = {
+ 'console_scripts' : [
+ 'startforum = askbot.deployment:startforum',
+ ]
+ },
+ url = 'http://askbot.org',
+ include_package_data = True,
+ install_requires = install_requires,
+ classifiers = [
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Web Environment',
+ 'Framework :: Django',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Natural Language :: English',
+ 'Natural Language :: German',
+ 'Natural Language :: Russian',
+ 'Natural Language :: Serbian',
+ 'Natural Language :: Turkish',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python :: 2.4',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: JavaScript',
+ 'Topic :: Communications :: Usenet News',
+ 'Topic :: Communications :: Email :: Mailing List Servers',
+ 'Topic :: Communications',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI :: Application',
+ ],
+ long_description = """Open Source Question and Answer forum.
+ Based on CNPROG project by Mike Chen and Sailing Cai, project
+ inspired by StackOverflow.
+ """,
+)
+
+if sys.platform in WIN_PLATFORMS:
+ print 'ATTENTION!! please install windows binary mysql-python package'
+ print 'at http://www.codegood.com/archives/4'
+
+print '**************************************************************'
+print '* *'
+print '* Thanks for installing Askbot. *'
+print '* To start deploying type: >startforum *'
+print '* Please take a look at the manual askbot/doc/INSTALL *'
+print '* And please do not hesitate to ask your questions at *'
+print '* at http://askbot.org *'
+print '* *'
+print '**************************************************************'