summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEvgeny Fadeev <evgeny.fadeev@gmail.com>2011-03-28 23:03:16 -0400
committerEvgeny Fadeev <evgeny.fadeev@gmail.com>2011-03-28 23:03:16 -0400
commit96a9863db21fc84af38ee28684807849ade25b97 (patch)
tree09d752e19aab3f4deb31d77ec68c2f12b48ace57 /setup.py
parent8ae8fcdc858af16e8f2d5ab87ae1a833cde52356 (diff)
downloadaskbot-96a9863db21fc84af38ee28684807849ade25b97.tar.gz
askbot-96a9863db21fc84af38ee28684807849ade25b97.tar.bz2
askbot-96a9863db21fc84af38ee28684807849ade25b97.zip
expanded range of supported versions of django and added patches for csrf_token
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 6 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 198aacaf..a76dc68e 100644
--- a/setup.py
+++ b/setup.py
@@ -7,9 +7,9 @@ import sys
#you might want to install django-debug-toolbar as well
install_requires = [
- 'django==1.1.2',
+ 'django>=1.1.2',
'Jinja2',
- 'Coffin==0.3.0',
+ 'Coffin>=0.3',
'South>=0.7.1',
'oauth2',
'recaptcha-client',
@@ -24,7 +24,9 @@ install_requires = [
'django-kombu==0.9.2',
]
-import askbot
+#todo: have a dirty version retriever that
+#parses it out from askbot/__init__.py but does not
+#import it as there are issues
WIN_PLATFORMS = ('win32', 'cygwin',)
if sys.platform not in WIN_PLATFORMS:
@@ -32,7 +34,7 @@ if sys.platform not in WIN_PLATFORMS:
setup(
name = "askbot",
- version = askbot.get_version(),
+ version = '0.6.75',#remember to manually set this correctly
description = 'Question and Answer forum, like StackOverflow, written in python and Django',
packages = find_packages(),
author = 'Evgeny.Fadeev',