summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEvgeny Fadeev <evgeny.fadeev@gmail.com>2011-04-27 12:32:54 -0400
committerEvgeny Fadeev <evgeny.fadeev@gmail.com>2011-04-27 12:32:54 -0400
commitb8b18378669f57484ab7f4bdae49f8e6c99cac23 (patch)
tree5ecdf4fe93cf23f5b5dffe4b35d9db34fed1e323 /setup.py
parent8b3ab52c3f7255bde44a0bf3534a569055acf1a2 (diff)
downloadaskbot-b8b18378669f57484ab7f4bdae49f8e6c99cac23.tar.gz
askbot-b8b18378669f57484ab7f4bdae49f8e6c99cac23.tar.bz2
askbot-b8b18378669f57484ab7f4bdae49f8e6c99cac23.zip
fixed issue with migration 22 on mysql and django >= 1.2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e5ff3250..cd3e5e86 100644
--- a/setup.py
+++ b/setup.py
@@ -27,6 +27,7 @@ install_requires = [
#todo: have a dirty version retriever that
#parses it out from askbot/__init__.py but does not
#import it as there are issues
+import askbot
WIN_PLATFORMS = ('win32', 'cygwin',)
if sys.platform not in WIN_PLATFORMS:
@@ -34,7 +35,7 @@ if sys.platform not in WIN_PLATFORMS:
setup(
name = "askbot",
- version = '0.6.80',#remember to manually set this correctly
+ version = askbot.get_version(),#version comes from askbot/__init__.py
description = 'Question and Answer forum, like StackOverflow, written in python and Django',
packages = find_packages(),
author = 'Evgeny.Fadeev',
@@ -150,7 +151,7 @@ if 'WIN_PLATFORM' in locals() and sys.platform in WIN_PLATFORMS:
print '**************************************************************'
print '* *'
print '* Thanks for installing Askbot. *'
-print '* To start deploying type: >python startforum *'
+print '* To start deploying type: > startforum *'
print '* Please take a look at the manual askbot/doc/INSTALL *'
print '* And please do not hesitate to ask your questions at *'
print '* at http://askbot.org *'