summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEvgeny Fadeev <evgeny.fadeev@gmail.com>2010-09-08 16:26:08 -0400
committerEvgeny Fadeev <evgeny.fadeev@gmail.com>2010-09-08 16:26:08 -0400
commitf9a96b0ec2bc2d144aeab451b8825d074f9a25b6 (patch)
treee429998d6c9d59f48f1ea4b484d1d95a5c3a1b75 /setup.py
parentbd88960adff37dbc33af6b9458f2800abf5cc11d (diff)
downloadaskbot-f9a96b0ec2bc2d144aeab451b8825d074f9a25b6.tar.gz
askbot-f9a96b0ec2bc2d144aeab451b8825d074f9a25b6.tar.bz2
askbot-f9a96b0ec2bc2d144aeab451b8825d074f9a25b6.zip
removed debug toolbar from dependencies, b/c developers can enable it themselves
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 55d9a67c..ac2e78ba 100644
--- a/setup.py
+++ b/setup.py
@@ -3,9 +3,12 @@ ez_setup.use_setuptools()
from setuptools import setup, find_packages
import sys
+#NOTE: if you want to develop askbot
+#you might want to install django-debug-toolbar as well
+
install_requires = [
'django==1.1.2',
- 'django-debug-toolbar==0.7.0',
+ #'django-debug-toolbar==0.7.0',
'South>=0.7.1',
'recaptcha-client',
'markdown2',
@@ -65,7 +68,7 @@ setup(
""",
)
-if sys.platform in WIN_PLATFORMS:
+if WIN_PLATFORM in locals() and sys.platform in WIN_PLATFORMS:
print 'ATTENTION!! please install windows binary mysql-python package'
print 'at http://www.codegood.com/archives/4'