summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 23 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 39b408c3..565eb190 100644
--- a/setup.py
+++ b/setup.py
@@ -6,12 +6,13 @@ import sys
install_requires = [
'django==1.1.2',
'django-debug-toolbar==0.7.0',
- 'South',
+ 'South>=0.7.1',
'recaptcha-client',
'markdown2',
'html5lib',
'python-openid',
'django-keyedcache',
+ 'django-threaded-multihost',
]
WIN_PLATFORMS = ('win32', 'cygwin',)
if sys.platform not in WIN_PLATFORMS:
@@ -34,6 +35,27 @@ setup(
url = 'http://askbot.org',
include_package_data = True,
install_requires = install_requires,
+ classifiers = [
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Web Environment',
+ 'Framework :: Django',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'Natural Language :: English',
+ 'Natural Language :: German',
+ 'Natural Language :: Russian',
+ 'Natural Language :: Serbian',
+ 'Natural Language :: Turkish',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python :: 2.4',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: JavaScript',
+ 'Topic :: Communications :: Usenet News',
+ 'Topic :: Communications :: Email :: Mailing List Servers',
+ 'Topic :: Communications',
+ 'Topic :: Internet :: WWW/HTTP :: WSGI :: Application',
+ ],
long_description = """Open Source Question and Answer forum.
Based on CNPROG project by Mike Chen and Sailing Cai, project
inspired by StackOverflow.