summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 1 insertions, 23 deletions
diff --git a/setup.py b/setup.py
index 253f9db9..2227aba3 100644
--- a/setup.py
+++ b/setup.py
@@ -6,28 +6,6 @@ import sys
#NOTE: if you want to develop askbot
#you might want to install django-debug-toolbar as well
-install_requires = [
- 'akismet',
- 'django>=1.1.2',
- 'Jinja2',
- 'Coffin>=0.3',
- 'South>=0.7.1',
- 'oauth2',
- 'markdown2',
- 'html5lib',
- 'django-keyedcache',
- 'django-threaded-multihost',
- 'django-robots',
- 'unidecode',
- 'django-countries==1.0.5',
- 'django-celery==2.2.7',
- 'django-kombu==0.9.2',
- 'django-followit',
- 'django-recaptcha-works',
- 'python-openid',
- 'pystache==0.3.1',
-]
-
import askbot
setup(
@@ -46,7 +24,7 @@ setup(
},
url = 'http://askbot.org',
include_package_data = True,
- install_requires = install_requires,
+ install_requires = askbot.REQUIREMENTS.values(),
classifiers = [
'Development Status :: 4 - Beta',
'Environment :: Web Environment',