summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index be0d4268..e17543f5 100644
--- a/setup.py
+++ b/setup.py
@@ -7,6 +7,7 @@ import sys
#you might want to install django-debug-toolbar as well
install_requires = [
+ 'django==1.1.2',
'South>=0.7.1',
'recaptcha-client',
'markdown2',
@@ -19,6 +20,10 @@ install_requires = [
import askbot
+WIN_PLATFORMS = ('win32', 'cygwin',)
+if sys.platform not in WIN_PLATFORMS:
+ install_requires.append('mysql-python')
+
setup(
name = "askbot",
version = askbot.get_version(),