summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEvgeny Fadeev <evgeny.fadeev@gmail.com>2010-09-11 19:35:00 -0400
committerEvgeny Fadeev <evgeny.fadeev@gmail.com>2010-09-11 19:35:00 -0400
commitcb09dd64924628e0646342538d2512439b7c3eba (patch)
treef4e72953c72114a906c3c2d2618824e4bd955e55 /setup.py
parentce5f99a29f1f7c4d6ed704fb4974e70ba4defe58 (diff)
downloadaskbot-cb09dd64924628e0646342538d2512439b7c3eba.tar.gz
askbot-cb09dd64924628e0646342538d2512439b7c3eba.tar.bz2
askbot-cb09dd64924628e0646342538d2512439b7c3eba.zip
finished merge with Omat's change and added setting to enable/disable slugs
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index be0d4268..e17543f5 100644
--- a/setup.py
+++ b/setup.py
@@ -7,6 +7,7 @@ import sys
#you might want to install django-debug-toolbar as well
install_requires = [
+ 'django==1.1.2',
'South>=0.7.1',
'recaptcha-client',
'markdown2',
@@ -19,6 +20,10 @@ install_requires = [
import askbot
+WIN_PLATFORMS = ('win32', 'cygwin',)
+if sys.platform not in WIN_PLATFORMS:
+ install_requires.append('mysql-python')
+
setup(
name = "askbot",
version = askbot.get_version(),