summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 9 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 55d9a67c..e17543f5 100644
--- a/setup.py
+++ b/setup.py
@@ -3,9 +3,11 @@ ez_setup.use_setuptools()
from setuptools import setup, find_packages
import sys
+#NOTE: if you want to develop askbot
+#you might want to install django-debug-toolbar as well
+
install_requires = [
'django==1.1.2',
- 'django-debug-toolbar==0.7.0',
'South>=0.7.1',
'recaptcha-client',
'markdown2',
@@ -13,13 +15,15 @@ install_requires = [
'django-keyedcache',
'django-threaded-multihost',
'django-robots',
+ 'unidecode',
]
+
+import askbot
+
WIN_PLATFORMS = ('win32', 'cygwin',)
if sys.platform not in WIN_PLATFORMS:
install_requires.append('mysql-python')
-import askbot
-
setup(
name = "askbot",
version = askbot.get_version(),
@@ -65,14 +69,14 @@ setup(
""",
)
-if sys.platform in WIN_PLATFORMS:
+if 'WIN_PLATFORM' in locals() and sys.platform in WIN_PLATFORMS:
print 'ATTENTION!! please install windows binary mysql-python package'
print 'at http://www.codegood.com/archives/4'
print '**************************************************************'
print '* *'
print '* Thanks for installing Askbot. *'
-print '* To start deploying type: >startforum *'
+print '* To start deploying type: >python startforum *'
print '* Please take a look at the manual askbot/doc/INSTALL *'
print '* And please do not hesitate to ask your questions at *'
print '* at http://askbot.org *'