summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorSol Jerome <sol.jerome@gmail.com>2012-04-05 10:00:58 -0500
committerSol Jerome <sol.jerome@gmail.com>2012-04-05 10:00:58 -0500
commit09e27b08889c9694e38c5bd384424c31433039a3 (patch)
tree714da39331fdae3a23f794530bd8bc4da0391ac2 /debian/rules
parent42c352357f9c8a95183cc302ebd9368fb72fe0ae (diff)
downloadbcfg2-09e27b08889c9694e38c5bd384424c31433039a3.tar.gz
bcfg2-09e27b08889c9694e38c5bd384424c31433039a3.tar.bz2
bcfg2-09e27b08889c9694e38c5bd384424c31433039a3.zip
debian: Add bcfg2-doc package
Signed-off-by: Sol Jerome <sol.jerome@gmail.com>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 8 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 1638b8415..30fd64a43 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,9 +1,7 @@
#!/usr/bin/make -f
-WSGI_LOC = $(shell find debian/bcfg2-server/ -name reports.wsgi | perl -p -e 's|debian/bcfg2-server||')
-
%:
- dh --with python-support $@
+ dh $@ --with python-support,sphinxdoc
override_dh_auto_install:
# Make the build destination dir consistent between pre-7.3 and 7.3 and
@@ -18,3 +16,10 @@ override_dh_installinit:
# Install bcfg2-server initscript without starting it on postinst
dh_installinit --package=bcfg2-server --no-start
+override_dh_installdocs:
+ python setup.py build_sphinx
+ dh_installdocs build/sphinx/html
+
+override_dh_auto_clean:
+ dh_auto_clean
+ rm -rf build