summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorNarayan Desai <desai@mcs.anl.gov>2004-08-11 19:59:50 +0000
committerNarayan Desai <desai@mcs.anl.gov>2004-08-11 19:59:50 +0000
commit69714e7a7dc8baed46c24f9580669bc4a3dca022 (patch)
tree82b1ed7ed4acb3a13a9973c5e94d538874d939d9 /debian/rules
parent114153e4ed7a25f6ed30b99ae390614406b2b588 (diff)
downloadbcfg2-69714e7a7dc8baed46c24f9580669bc4a3dca022.tar.gz
bcfg2-69714e7a7dc8baed46c24f9580669bc4a3dca022.tar.bz2
bcfg2-69714e7a7dc8baed46c24f9580669bc4a3dca022.zip
(Logical change 1.35)
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@199 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'debian/rules')
-rw-r--r--debian/rules76
1 files changed, 76 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index e69de29bb..b920eeceb 100644
--- a/debian/rules
+++ b/debian/rules
@@ -0,0 +1,76 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# GNU copyright 1997 to 1999 by Joey Hess.
+
+# Uncomment this to turn on verbose mode.
+export DH_VERBOSE=1
+
+CFLAGS = -Wall -g
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+build:
+ python setup.py build
+
+clean:
+ dh_testdir
+ dh_testroot
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+ python setup.py install --prefix=$(PWD)/debian/tmp/usr
+
+# Build architecture-dependent files here.
+# We have nothing to do by default.
+binary-arch: build install
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+# dh_installexamples
+ mv debian/tmp/usr/bin debian/tmp/usr/sbin
+ dh_install
+ rm debian/tmp/usr/sbin/Bcfg2Server
+ rm -Rf debian/tmp/usr/lib/python2.3/site-packages/Bcfg2/Server
+# chmod 600 debian/bcfg-server/etc/bcfgd.conf
+# chmod 755 debian/bcfg*/usr/sbin/*
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit -pbcfg-server --name bcfgd -u"start 21 2 3 4 5 . stop 19 0 1 6 ."
+# dh_installcron
+# dh_installinfo
+ dh_installman
+# dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+ dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install