summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorNarayan Desai <desai@mcs.anl.gov>2006-08-01 02:02:08 +0000
committerNarayan Desai <desai@mcs.anl.gov>2006-08-01 02:02:08 +0000
commit8b6e761baac8bb93e631da2e405d3f1e49b01916 (patch)
treec7f668729f80d3fc3d7cbb92465db81f49bbbad5 /debian/rules
parenta5733c06ab8b7491aaf9dcc6e15d7d14016d8806 (diff)
downloadbcfg2-8b6e761baac8bb93e631da2e405d3f1e49b01916.tar.gz
bcfg2-8b6e761baac8bb93e631da2e405d3f1e49b01916.tar.bz2
bcfg2-8b6e761baac8bb93e631da2e405d3f1e49b01916.zip
Packaging changes from ressu
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@2019 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules18
1 files changed, 9 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index bcd55d66c..2cb0ecd74 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,13 +17,13 @@ include /usr/share/cdbs/1/class/python-distutils.mk
DEB_PYTHON_VERSIONS = 2.3
# Since cdbs is able to handle only one python package at once do things here:
-#binary-install/bcfg2-server :: binary-install/%:
+binary-install/bcfg2-server :: binary-install/%:
# Mostly borrowed from /usr/share/cdbs/1/class/python-distutils.mk
-#ifdef _cdbs_rules_debhelper
-# ifeq (pysupport, $(DEB_PYTHON_SYSTEM))
-# dh_pysupport -pbcfg2-server $(DEB_PYTHON_PRIVATE_MODULES_DIRS)
-# else
-# dh_pycentral -pbcfg2-server
-# endif
-# dh_python -pbcfg2-server $(DEB_PYTHON_PRIVATE_MODULES_DIRS)
-#endif
+ifdef DEB_PYTHON_SYSTEM
+ ifeq (pysupport, $(DEB_PYTHON_SYSTEM))
+ dh_pysupport -pbcfg2-server $(DEB_PYTHON_PRIVATE_MODULES_DIRS)
+ else
+ dh_pycentral -pbcfg2-server
+ endif
+endif
+ dh_python -pbcfg2-server $(DEB_PYTHON_PRIVATE_MODULES_DIRS)