summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Joseph Barnhart Clark <dclark@pobox.com>2009-11-10 06:01:55 +0000
committerDaniel Joseph Barnhart Clark <dclark@pobox.com>2009-11-10 06:01:55 +0000
commitc43240b152b13d5ed0d0728ccfcc6eed4c7ef451 (patch)
treea008f40e114f8702ab25b450c2a2a31aa5adf604 /debian/rules
parentd14eef57303c4b9cef33fa97b71e12aa25e6bd0a (diff)
downloadbcfg2-c43240b152b13d5ed0d0728ccfcc6eed4c7ef451.tar.gz
bcfg2-c43240b152b13d5ed0d0728ccfcc6eed4c7ef451.tar.bz2
bcfg2-c43240b152b13d5ed0d0728ccfcc6eed4c7ef451.zip
try at fix for #791 - sort of ugly, with shallow testing seems to work
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@5564 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 7 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 033aed4c8..3c5be6f52 100755
--- a/debian/rules
+++ b/debian/rules
@@ -2,6 +2,13 @@
%:
dh --with python-support $@
+override_dh_auto_install:
+ # Make the build destination dir consistent between pre-7.3 and 7.3 and
+ # later debhelper - see http://bcfg2.org/ticket/791
+ dh_auto_install
+ test -d debian/tmp/usr/local && mv debian/tmp/usr/local/* debian/tmp/usr || exit 0
+ test -d debian/tmp/usr/local && rmdir debian/tmp/usr/local || exit 0
+
override_dh_installinit:
# Install bcfg2 initscript without staring it on postinst
dh_installinit --package=bcfg2 --no-start