summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorTim Laszlo <tim.laszlo@gmail.com>2010-10-19 16:06:35 -0500
committerTim Laszlo <tim.laszlo@gmail.com>2010-10-19 16:42:09 -0500
commit21ede8dae0e372a797f546ad8c0e4ace72cb9ec5 (patch)
tree64b8e3d9b34a4708fc38c897ad28788103ff6541 /debian
parent9a981769c88e8478693688087eb0f4b99d0188a6 (diff)
downloadbcfg2-21ede8dae0e372a797f546ad8c0e4ace72cb9ec5.tar.gz
bcfg2-21ede8dae0e372a797f546ad8c0e4ace72cb9ec5.tar.bz2
bcfg2-21ede8dae0e372a797f546ad8c0e4ace72cb9ec5.zip
web_reports: debian reports package
Diffstat (limited to 'debian')
-rw-r--r--debian/bcfg2-server.install4
-rw-r--r--debian/bcfg2-web.install2
-rw-r--r--debian/control9
-rwxr-xr-xdebian/rules9
4 files changed, 23 insertions, 1 deletions
diff --git a/debian/bcfg2-server.install b/debian/bcfg2-server.install
index 859806fa0..91b1b2aef 100644
--- a/debian/bcfg2-server.install
+++ b/debian/bcfg2-server.install
@@ -1,5 +1,7 @@
debian/bcfg2-server.default usr/share/bcfg2
debian/tmp/usr/bin/bcfg2-* usr/sbin
debian/tmp/usr/lib/python*/*-packages/Bcfg2/Server/*
-debian/tmp/usr/share/bcfg2/*
+debian/tmp/usr/share/bcfg2/Hostbase/*
+debian/tmp/usr/share/bcfg2/schemas/*
+debian/tmp/usr/share/bcfg2/xsl-transforms/*
debian/tmp/usr/share/man/man8/*
diff --git a/debian/bcfg2-web.install b/debian/bcfg2-web.install
new file mode 100644
index 000000000..bfa55a925
--- /dev/null
+++ b/debian/bcfg2-web.install
@@ -0,0 +1,2 @@
+misc/apache/bcfg2.conf etc/apache2/conf.d/
+debian/tmp/usr/share/bcfg2/site_media/*
diff --git a/debian/control b/debian/control
index acfc6cc9c..726958c85 100644
--- a/debian/control
+++ b/debian/control
@@ -29,3 +29,12 @@ Description: Configuration management server
for clients bound by client profiles.
bcfg2-server is the server for bcfg2 clients, which generates configuration
sets and stores statistics of client system states.
+
+Package: bcfg2-web
+Architecture: all
+Depends: ${python:Depends}, ${misc:Depends}, bcfg2 (= ${binary:Version}), python-django, libapache2-mod-wsgi
+XB-Python-Version: >= 2.4
+Description: Configuration management web interface
+ Bcfg2 is a configuration management system that generates configuration sets
+ for clients bound by client profiles.
+ bcfg2-web is the reporting server for bcfg2.
diff --git a/debian/rules b/debian/rules
index 928b3d2d3..928880859 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,4 +1,7 @@
#!/usr/bin/make -f
+
+WSGI_LOC = $(shell find debian/bcfg2-server/ -name reports.wsgi | perl -p -e 's|debian/bcfg2-server||')
+
%:
dh --with python-support $@
@@ -14,3 +17,9 @@ override_dh_installinit:
dh_installinit --package=bcfg2 --no-start
# Install bcfg2-server initscript without starting it on postinst
dh_installinit --package=bcfg2-server --no-start
+
+override_dh_installdeb:
+ dh_installdeb
+ perl -pi -e 's/^.*LoadModule.*//' debian/bcfg2-web/etc/apache2/conf.d/bcfg2.conf
+ perl -pi -e 's|/usr.*/reports.wsgi|$(WSGI_LOC)|' debian/bcfg2-web/etc/apache2/conf.d/bcfg2.conf
+