summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorSol Jerome <sol.jerome@gmail.com>2013-06-10 19:44:10 -0500
committerSol Jerome <sol.jerome@gmail.com>2013-06-10 19:44:10 -0500
commit2907481679db553bedfe076cb9dbcb83d011695b (patch)
treed102a4ef20657b577ce2c6ce7ee97a068184f015 /debian
parent015d87d0873fb58c84204210407d4ea17582cf7a (diff)
downloadbcfg2-2907481679db553bedfe076cb9dbcb83d011695b.tar.gz
bcfg2-2907481679db553bedfe076cb9dbcb83d011695b.tar.bz2
bcfg2-2907481679db553bedfe076cb9dbcb83d011695b.zip
debian: Update rules to use dh_python2
Signed-off-by: Sol Jerome <sol.jerome@gmail.com>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 5694e4e37..18d55b8f4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,12 @@
#!/usr/bin/make -f
+# Lucid does not have dh_python2, but we would like to be able to use
+# this rules file to build on lucid as well.
+WITH_PYTHON2 = $(shell test -f /usr/bin/dh_python2 && echo "--with python2")
+WITH_SPHINXDOC = $(shell test -f /usr/bin/dh_sphinxdoc && echo "--with sphinxdoc")
+
%:
- dh $@ --with python-support,sphinxdoc
+ dh $@ ${WITH_PYTHON2} ${WITH_SPHINXDOC}
override_dh_installinit:
# Install bcfg2 initscript without starting it on postinst