summaryrefslogtreecommitdiffstats
path: root/gentoo
diff options
context:
space:
mode:
authorNarayan Desai <desai@mcs.anl.gov>2007-02-01 23:51:02 +0000
committerNarayan Desai <desai@mcs.anl.gov>2007-02-01 23:51:02 +0000
commit4654401ee1cff559c2f4af7344870c487de13276 (patch)
tree20e6c27b8dc5e682b78666174698654ee98d25a4 /gentoo
parent3162939da7bd489a76f0f117923850bc5025355d (diff)
downloadbcfg2-4654401ee1cff559c2f4af7344870c487de13276.tar.gz
bcfg2-4654401ee1cff559c2f4af7344870c487de13276.tar.bz2
bcfg2-4654401ee1cff559c2f4af7344870c487de13276.zip
Version bump to 0.9.1a
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@2766 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'gentoo')
-rw-r--r--gentoo/bcfg2-0.9.1a.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/gentoo/bcfg2-0.9.1a.ebuild b/gentoo/bcfg2-0.9.1a.ebuild
new file mode 100644
index 000000000..76e5bee0c
--- /dev/null
+++ b/gentoo/bcfg2-0.9.1a.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Bcfg2 is a configuration management tool. Package includes client
+and server."
+HOMEPAGE="http://www.mcs.anl.gov/cobalt/bcfg2"
+
+# handle the "pre" case
+MY_P="${P/_/}"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-portage/gentoolkit
+ dev-python/elementtree
+ dev-python/pyopenssl
+ dev-python/lxml
+ ( || ( app-admin/gamin
+ app-admin/fam ) )"
+
+RDEPEND=""
+
+src_compile() {
+ python setup.py build
+}
+
+src_install() {
+ install -d ${D}/usr/sbin
+ install -d ${D}/etc/init.d
+ exeinto /etc/init.d
+ exeopts -m0755
+ newexe ${FILESDIR}/bcfg2-server.rc bcfg2-server
+ python setup.py install \
+ --root=${D} \
+ --record=PY_SERVER_LIBS \
+ --install-scripts /usr/sbin
+}
+
+pkg_postinst () {
+ depscan.sh
+}
+
+pkg_postrm () {
+ depscan.sh
+}