summaryrefslogtreecommitdiffstats
path: root/gentoo
diff options
context:
space:
mode:
authorNarayan Desai <desai@mcs.anl.gov>2008-04-16 23:42:46 +0000
committerNarayan Desai <desai@mcs.anl.gov>2008-04-16 23:42:46 +0000
commit49dad5f9022a32426fb1213fb1fad5b49fe314f5 (patch)
tree057576ee6b7aece0a23ca315bc9cc92afddb569b /gentoo
parente5741b35538a80451f1dfadb47abebb1723ef532 (diff)
downloadbcfg2-49dad5f9022a32426fb1213fb1fad5b49fe314f5.tar.gz
bcfg2-49dad5f9022a32426fb1213fb1fad5b49fe314f5.tar.bz2
bcfg2-49dad5f9022a32426fb1213fb1fad5b49fe314f5.zip
new ebuild script (with server use flag) (from Kamil Kisiel)
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@4547 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'gentoo')
-rw-r--r--gentoo/bcfg2-0.9.6_pre1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/gentoo/bcfg2-0.9.6_pre1.ebuild b/gentoo/bcfg2-0.9.6_pre1.ebuild
new file mode 100644
index 000000000..494588d0e
--- /dev/null
+++ b/gentoo/bcfg2-0.9.6_pre1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Bcfg2 is a configuration management tool. Package includes client
+and server."
+HOMEPAGE="http://trac.mcs.anl.gov/projects/bcfg2"
+
+# handle the "pre" case
+MY_P="${P/_/}"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+RESTRICT="mirror"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="server"
+
+DEPEND="
+ app-portage/gentoolkit
+
+ || ( >=dev-lang/python-2.5
+ (
+ >=dev-lang/python-2.3
+ || ( dev-python/elementtree dev-python/lxml )
+ )
+ )
+ "
+
+RDEPEND="
+ server? (
+ dev-python/pyopenssl
+ || ( app-admin/gamin app-admin/fam )
+ )
+ "
+
+src_compile() {
+ python setup.py build
+}
+
+src_install() {
+ python setup.py install \
+ --root=${D} \
+ --record=PY_SERVER_LIBS \
+ --install-scripts /usr/sbin
+
+ # Remove files only necessary for a server installation
+ if ! use server; then
+ rm -rf ${D}/usr/sbin/bcfg2-*
+ rm -rf ${D}/usr/share/bcfg2
+ rm -rf ${D}/usr/share/man/man8
+ fi
+
+ # Install a server init.d script
+ if use server; then
+ newinitd ${FILESDIR}/bcfg2-server.rc bcfg2-server
+ fi
+
+ insinto /etc
+ doins ${S}/examples/bcfg2.conf
+}
+
+pkg_postinst () {
+ depscan.sh
+}
+
+pkg_postrm () {
+ depscan.sh
+}