summaryrefslogtreecommitdiffstats
path: root/gentoo
diff options
context:
space:
mode:
authorSol Jerome <sol.jerome@gmail.com>2012-01-09 11:16:11 -0600
committerSol Jerome <sol.jerome@gmail.com>2012-01-09 11:19:13 -0600
commit4b8b004dfa5a976459a86f7635dabcfb8bd3cf4e (patch)
treed3608a477bc981a90c98c5d841069fe797f53e49 /gentoo
parent82cdfeba16096145c1fc8e6bd800760809e7f580 (diff)
downloadbcfg2-4b8b004dfa5a976459a86f7635dabcfb8bd3cf4e.tar.gz
bcfg2-4b8b004dfa5a976459a86f7635dabcfb8bd3cf4e.tar.bz2
bcfg2-4b8b004dfa5a976459a86f7635dabcfb8bd3cf4e.zip
gentoo: Sync ebuild with upstream
Signed-off-by: Sol Jerome <sol.jerome@gmail.com>
Diffstat (limited to 'gentoo')
-rw-r--r--gentoo/bcfg2-1.2.0.ebuild (renamed from gentoo/bcfg2-1.1.2.ebuild)15
1 files changed, 6 insertions, 9 deletions
diff --git a/gentoo/bcfg2-1.1.2.ebuild b/gentoo/bcfg2-1.2.0.ebuild
index 4da67d865..cd1d368d1 100644
--- a/gentoo/bcfg2-1.1.2.ebuild
+++ b/gentoo/bcfg2-1.2.0.ebuild
@@ -10,7 +10,7 @@ RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
inherit distutils
-DESCRIPTION="Bcfg2 is a configuration management tool."
+DESCRIPTION="configuration management tool"
HOMEPAGE="http://bcfg2.org"
# handle the "pre" case
@@ -23,11 +23,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
IUSE="server"
-DEPEND="app-portage/gentoolkit
+DEPEND=""
+RDEPEND="app-portage/gentoolkit
server? (
dev-python/lxml
- app-admin/gam-server )"
-RDEPEND="${DEPEND}"
+ dev-libs/libgamin[python] )"
PYTHON_MODNAME="Bcfg2"
@@ -40,14 +40,11 @@ distutils_src_install_post_hook() {
src_install() {
distutils_src_install --record=PY_SERVER_LIBS --install-scripts "${EPREFIX}/usr/sbin"
- # Remove files only necessary for a server installation
if ! use server; then
+ # Remove files only necessary for a server installation
rm -rf "${ED}usr/share/bcfg2"
rm -rf "${ED}usr/share/man/man8"
- fi
-
- # Install a server init.d script
- if use server; then
+ else
newinitd "${FILESDIR}/bcfg2-server.rc" bcfg2-server
fi