summaryrefslogtreecommitdiffstats
path: root/gentoo
diff options
context:
space:
mode:
authorSol Jerome <solj@ices.utexas.edu>2009-06-14 20:43:34 +0000
committerSol Jerome <solj@ices.utexas.edu>2009-06-14 20:43:34 +0000
commit8e3c40dc2cc0d22eb9ad3f4863fbc40195eec6c6 (patch)
tree7cd53b69276609321778590be9dc79f1d0f7d278 /gentoo
parent8b76968c2b22e5df0fd7ed7c86379f32ac5d595d (diff)
downloadbcfg2-8e3c40dc2cc0d22eb9ad3f4863fbc40195eec6c6.tar.gz
bcfg2-8e3c40dc2cc0d22eb9ad3f4863fbc40195eec6c6.tar.bz2
bcfg2-8e3c40dc2cc0d22eb9ad3f4863fbc40195eec6c6.zip
Gentoo ebuild updates:
* Remove m2crypto dependency * Add ssl-py26 dependency Signed-off-by: Sol Jerome <solj@ices.utexas.edu> git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@5279 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'gentoo')
-rw-r--r--gentoo/bcfg2-1.0_pre3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/gentoo/bcfg2-1.0_pre3.ebuild b/gentoo/bcfg2-1.0_pre3.ebuild
new file mode 100644
index 000000000..6b366dcb0
--- /dev/null
+++ b/gentoo/bcfg2-1.0_pre3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Bcfg2 is a configuration management tool."
+HOMEPAGE="http://trac.mcs.anl.gov/projects/bcfg2"
+
+# handle the "pre" case
+MY_P="${P/_/}"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="server"
+
+DEPEND=">=dev-lang/python-2.5"
+
+RDEPEND="app-portage/gentoolkit
+ || ( dev-python/ssl-py26 >=dev-lang/python-2.6 )
+ server? (
+ dev-python/lxml
+ app-admin/gam-server )"
+
+src_install() {
+ distutils_src_install --record=PY_SERVER_LIBS --install-scripts /usr/sbin
+
+ # Remove files only necessary for a server installation
+ if ! use server; then
+ rm -rf "${D}"/usr/sbin/bcfg2-*
+ rm -rf "${D}"/usr/share/bcfg2
+ rm -rf "${D}"/usr/share/man/man8
+ fi
+
+ # Install a server init.d script
+ if use server; then
+ newinitd "${FILESDIR}"/bcfg2-server.rc bcfg2-server
+ fi
+
+ insinto /etc
+ doins "${S}"/examples/bcfg2.conf
+}
+
+pkg_postinst () {
+ depscan.sh
+ use server && einfo "If this is a new installation, you probably need to run: "
+ use server && einfo " bcfg2-admin init"
+}
+
+pkg_postrm () {
+ depscan.sh
+}