summaryrefslogtreecommitdiffstats
path: root/gentoo
diff options
context:
space:
mode:
authorMichael Jinks <mjinks@uchicago.edu>2007-02-01 06:33:04 +0000
committerMichael Jinks <mjinks@uchicago.edu>2007-02-01 06:33:04 +0000
commita88c2d9c06568bd168d195d9aac35fe0958eb598 (patch)
treeebb9ec0b56d6d23aedec6b0a08339ff4c44d3a5b /gentoo
parent533403bdf5b7fdd92a20ab8d528cfd6e2625b638 (diff)
downloadbcfg2-a88c2d9c06568bd168d195d9aac35fe0958eb598.tar.gz
bcfg2-a88c2d9c06568bd168d195d9aac35fe0958eb598.tar.bz2
bcfg2-a88c2d9c06568bd168d195d9aac35fe0958eb598.zip
Example ebuild file, add to /usr/local/portage/app-admin/bcfg2 or similar
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@2751 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'gentoo')
-rw-r--r--gentoo/bcfg2-0.9.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/gentoo/bcfg2-0.9.0.ebuild b/gentoo/bcfg2-0.9.0.ebuild
new file mode 100644
index 000000000..76e5bee0c
--- /dev/null
+++ b/gentoo/bcfg2-0.9.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+DESCRIPTION="Bcfg2 is a configuration management tool. Package includes client
+and server."
+HOMEPAGE="http://www.mcs.anl.gov/cobalt/bcfg2"
+
+# handle the "pre" case
+MY_P="${P/_/}"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="app-portage/gentoolkit
+ dev-python/elementtree
+ dev-python/pyopenssl
+ dev-python/lxml
+ ( || ( app-admin/gamin
+ app-admin/fam ) )"
+
+RDEPEND=""
+
+src_compile() {
+ python setup.py build
+}
+
+src_install() {
+ install -d ${D}/usr/sbin
+ install -d ${D}/etc/init.d
+ exeinto /etc/init.d
+ exeopts -m0755
+ newexe ${FILESDIR}/bcfg2-server.rc bcfg2-server
+ python setup.py install \
+ --root=${D} \
+ --record=PY_SERVER_LIBS \
+ --install-scripts /usr/sbin
+}
+
+pkg_postinst () {
+ depscan.sh
+}
+
+pkg_postrm () {
+ depscan.sh
+}