summaryrefslogtreecommitdiffstats
path: root/gentoo
diff options
context:
space:
mode:
authorSol Jerome <solj@ices.utexas.edu>2009-05-11 17:13:14 +0000
committerSol Jerome <solj@ices.utexas.edu>2009-05-11 17:13:14 +0000
commitacb08a52b4287d1da3ab5429a63b8be187ec6149 (patch)
tree467014709f632aa732cde87969943ca71b53233a /gentoo
parentd0d32c1cb5c5c35f897431cffa3b7ca9286d6c0d (diff)
downloadbcfg2-acb08a52b4287d1da3ab5429a63b8be187ec6149.tar.gz
bcfg2-acb08a52b4287d1da3ab5429a63b8be187ec6149.tar.bz2
bcfg2-acb08a52b4287d1da3ab5429a63b8be187ec6149.zip
Merge bcfg2 ebuild from Gentoo
Signed-off-by: Sol Jerome <solj@ices.utexas.edu> git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@5217 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'gentoo')
-rw-r--r--gentoo/bcfg2-1.0_pre2.ebuild51
1 files changed, 18 insertions, 33 deletions
diff --git a/gentoo/bcfg2-1.0_pre2.ebuild b/gentoo/bcfg2-1.0_pre2.ebuild
index 494588d0e..dd4eab709 100644
--- a/gentoo/bcfg2-1.0_pre2.ebuild
+++ b/gentoo/bcfg2-1.0_pre2.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-DESCRIPTION="Bcfg2 is a configuration management tool. Package includes client
-and server."
+inherit distutils
+
+DESCRIPTION="Bcfg2 is a configuration management tool."
HOMEPAGE="http://trac.mcs.anl.gov/projects/bcfg2"
# handle the "pre" case
@@ -12,58 +13,42 @@ SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
-RESTRICT="mirror"
-
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="server"
-DEPEND="
- app-portage/gentoolkit
-
- || ( >=dev-lang/python-2.5
- (
- >=dev-lang/python-2.3
- || ( dev-python/elementtree dev-python/lxml )
- )
- )
- "
+DEPEND=">=dev-lang/python-2.5
+ dev-python/m2crypto"
-RDEPEND="
+RDEPEND="app-portage/gentoolkit
server? (
+ dev-python/lxml
dev-python/pyopenssl
- || ( app-admin/gamin app-admin/fam )
- )
- "
-
-src_compile() {
- python setup.py build
-}
+ app-admin/gam-server )"
src_install() {
- python setup.py install \
- --root=${D} \
- --record=PY_SERVER_LIBS \
- --install-scripts /usr/sbin
+ distutils_src_install --record=PY_SERVER_LIBS --install-scripts /usr/sbin
# Remove files only necessary for a server installation
if ! use server; then
- rm -rf ${D}/usr/sbin/bcfg2-*
- rm -rf ${D}/usr/share/bcfg2
- rm -rf ${D}/usr/share/man/man8
+ rm -rf "${D}"/usr/sbin/bcfg2-*
+ rm -rf "${D}"/usr/share/bcfg2
+ rm -rf "${D}"/usr/share/man/man8
fi
# Install a server init.d script
if use server; then
- newinitd ${FILESDIR}/bcfg2-server.rc bcfg2-server
+ newinitd "${FILESDIR}"/bcfg2-server.rc bcfg2-server
fi
insinto /etc
- doins ${S}/examples/bcfg2.conf
+ doins "${S}"/examples/bcfg2.conf
}
pkg_postinst () {
depscan.sh
+ use server && einfo "If this is a new installation, you probably need to run: "
+ use server && einfo " bcfg2-admin init"
}
pkg_postrm () {