summaryrefslogtreecommitdiffstats
path: root/gentoo
diff options
context:
space:
mode:
authorZach Lowry <zach@mcs.anl.gov>2005-07-15 16:13:42 +0000
committerZach Lowry <zach@mcs.anl.gov>2005-07-15 16:13:42 +0000
commite92cd59a4c5da1e95612097cf2a5ebe94c1d65b1 (patch)
tree39edab0ce58c94515d11277e5305e63104fc86a3 /gentoo
parentf75393e57c1cda3b19ca78bfdb622fca3783803e (diff)
downloadbcfg2-e92cd59a4c5da1e95612097cf2a5ebe94c1d65b1.tar.gz
bcfg2-e92cd59a4c5da1e95612097cf2a5ebe94c1d65b1.tar.bz2
bcfg2-e92cd59a4c5da1e95612097cf2a5ebe94c1d65b1.zip
(Logical change 1.268)
git-svn-id: https://svn.mcs.anl.gov/repos/bcfg/trunk/bcfg2@1090 ce84e21b-d406-0410-9b95-82705330c041
Diffstat (limited to 'gentoo')
-rw-r--r--gentoo/Manifest4
-rw-r--r--gentoo/bcfg2-0.6.9.2.ebuild160
-rw-r--r--gentoo/files/bcfg2-client26
-rw-r--r--gentoo/files/bcfg2-server24
-rw-r--r--gentoo/files/digest-bcfg2-0.6.9.21
5 files changed, 215 insertions, 0 deletions
diff --git a/gentoo/Manifest b/gentoo/Manifest
index e69de29bb..99d794b3c 100644
--- a/gentoo/Manifest
+++ b/gentoo/Manifest
@@ -0,0 +1,4 @@
+MD5 fcc4d9ab3b8f86cc321eb4dc6d7773f2 bcfg2-0.6.9.2.ebuild 6555
+MD5 0319c0bec91a2145e4903547f985bc72 files/digest-bcfg2-0.6.9.2 64
+MD5 154ef1df1a5183456498dfec8a314fd8 files/bcfg2-client 380
+MD5 a8af18995c8bf7f1cd87aba05bd9eefa files/bcfg2-server 491
diff --git a/gentoo/bcfg2-0.6.9.2.ebuild b/gentoo/bcfg2-0.6.9.2.ebuild
index e69de29bb..691358a96 100644
--- a/gentoo/bcfg2-0.6.9.2.ebuild
+++ b/gentoo/bcfg2-0.6.9.2.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+# NOTE: The comments in this file are for instruction and documentation.
+# They're not meant to appear with your final, production ebuild. Please
+# remember to remove them before submitting or committing your ebuild. That
+# doesn't mean you can't add your own comments though.
+
+# The 'Header' on the third line should just be left alone. When your ebuild
+# will be committed to cvs, the details on that line will be automatically
+# generated to contain the correct data.
+
+# Short one-line description of this package.
+DESCRIPTION="Bcfg2 is a prototype configuration management tool"
+
+# Homepage, not used by Portage directly but handy for developer reference
+HOMEPAGE="http://www.mcs.anl.gov/cobalt/bcfg2"
+
+# Point to any required sources; these will be automatically downloaded by
+# Portage.
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${P}.tar.gz"
+
+# License of the package. This must match the name of file(s) in
+# /usr/portage/licenses/. For complex license combination see the developer
+# docs on gentoo.org for details.
+LICENSE="BSD"
+
+# The SLOT variable is used to tell Portage if it's OK to keep multiple
+# versions of the same package installed at the same time. For example,
+# if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
+# with 1.2.2), it would be optimal to instruct Portage to not remove
+# libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2. To do this,
+# we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
+# emerge clean understands SLOTs, and will keep the most recent version
+# of each SLOT and remove everything else.
+# Note that normal applications should use SLOT="0" if possible, since
+# there should only be exactly one version installed at a time.
+# DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
+SLOT="0"
+
+# Using KEYWORDS, we can record masking information *inside* an ebuild
+# instead of relying on an external package.mask file. Right now, you
+# should set the KEYWORDS variable for every ebuild so that it contains
+# the names of all the architectures with which the ebuild works. We have
+# 4 official architecture names right now: "~x86", "~ppc", "~sparc"
+# and "~alpha". The ~ in front of the architecture indicates that the
+# package is new and should be considered unstable until testing proves its
+# stability. Once packages go stable the ~ prefix is removed.
+# So, if you've confirmed that your ebuild works on x86 and ppc,
+# you'd specify: KEYWORDS="~x86 ~ppc"
+# For packages that are platform-independent (like Java, PHP or Perl
+# applications) specify all keywords.
+# For binary packages, use -* and then list the archs the bin package
+# exists for. If the package was for an x86 binary package, then
+# KEYWORDS would be set like this: KEYWORDS="-* x86"
+# DO NOT USE KEYWORDS="*". This is deprecated and only for backward
+# compatibility reasons.
+KEYWORDS="~x86"
+
+# Comprehensive list of any and all USE flags leveraged in the ebuild,
+# with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
+# "x86" and "alpha". This is a required variable. If the
+# ebuild doesn't use any USE flags, set to "".
+IUSE=""
+
+# Build-time dependencies, such as
+# ssl? ( >=dev-libs/openssl-0.9.6b )
+# >=dev-lang/perl-5.6.1-r1
+# It is advisable to use the >= syntax show above, to reflect what you
+# had installed on your system when you tested the package. Then
+# other users hopefully won't be caught without the right version of
+# a dependency.
+DEPEND=">=sss-0.99_pre6
+ elementtree
+ fam"
+
+# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
+#RDEPEND=""
+
+# Source directory; the dir where the sources can be found (automatically
+# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
+# if you omit this line.
+S=${WORKDIR}/${P}
+
+src_compile() {
+ # Most open-source packages use GNU autoconf for configuration.
+ # You should use something similar to the following lines to
+ # configure your package before compilation. The "|| die" portion
+ # at the end will stop the build process if the command fails.
+ # You should use this at the end of critical commands in the build
+ # process. (Hint: Most commands are critical, that is, the build
+ # process should abort if they aren't successful.)
+ python setup.py build
+ # Note the use of --infodir and --mandir, above. This is to make
+ # this package FHS 2.2-compliant. For more information, see
+ # http://www.pathname.com/fhs/
+
+ # Also note that it is cleaner and easier to use econf, which is the
+ # portage shortcut to the above ./configure statement:
+ #
+ # econf || die
+ # Note that econf will die on failure, but plase use econf || die
+ # for consistency.
+
+ # emake (previously known as pmake) is a script that calls the
+ # standard GNU make with parallel building options for speedier
+ # builds (especially on SMP systems). Try emake first. It might
+ # not work for some packages, in which case you'll have to resort
+ # to normal "make".
+ #make || die
+}
+
+src_install() {
+ # You must *personally verify* that this trick doesn't install
+ # anything outside of DESTDIR; do this by reading and
+ # understanding the install part of the Makefiles.
+ #make DESTDIR=${D} install || die
+ install -d ${D}/usr/sbin
+ install -d ${D}/etc/init.d
+ exeinto /etc/init.d
+ exeopts -m0755
+ doexe ${FILESDIR}/bcfg2-server ${FILESDIR}/bcfg2-client
+ # dosbin bcfgd.py bcfgctl.py bcfg.py bcfg-refresh.py
+ # doman bcfg.1 bcfgctl.1 bcfgd.8 bcfgd.conf.5
+ # dodoc README LICENSE docs/*
+ # docinto examples
+ # dodoc test/*
+ python setup.py install --root=${D} --record=PY_SERVER_LIBS
+
+ # For Makefiles that don't make proper use of DESTDIR, setting
+ # prefix is often an alternative. However if you do this, then
+ # you also need to specify mandir and infodir, since they were
+ # passed to ./configure as absolute paths (overriding the prefix
+ # setting).
+ #make \
+ # prefix=${D}/usr \
+ # mandir=${D}/usr/share/man \
+ # infodir=${D}/usr/share/info \
+ # install || die
+ # Again, verify the Makefiles! We don't want anything falling
+ # outside of ${D}.Q
+ # `
+
+ # The portage shortcut to the above command is simply:
+ #
+ #einstall || die
+ # Note that einstall will die on failure, but please use einstall || die
+ # for consistency.
+}
+
+pkg_postinst () {
+ depscan.sh
+}
+
+pkg_postrm () {
+ [ -f /etc/init.d/bcfg2-client ] && rm -f /etc/init.d/bcfg2-client
+ [ -f /etc/init.d/bcfg2-server ] && rm -f /etc/init.d/bcfg2-server
+ depscan.sh
+}
diff --git a/gentoo/files/bcfg2-client b/gentoo/files/bcfg2-client
index e69de29bb..1d903c737 100644
--- a/gentoo/files/bcfg2-client
+++ b/gentoo/files/bcfg2-client
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+#
+# bcfg - bcfg configuration client
+#
+#
+
+depend () {
+ need net
+}
+
+start () {
+ ebegin "Starting bcfg"
+ if [ -e /etc/bcfg.dont_run ]; then
+ einfo "bcfg does not need to run"
+ eend 0
+ else
+ start-stop-daemon --start --quiet \
+ --startas /usr/sbin/bcfg.py -- -q -s
+ eend $? "Failed to start bcfg"
+ fi
+}
+stop () {
+ ebegin "Stopping bcfg"
+ /bin/true
+ eend 0
+}
diff --git a/gentoo/files/bcfg2-server b/gentoo/files/bcfg2-server
index e69de29bb..cb7848350 100644
--- a/gentoo/files/bcfg2-server
+++ b/gentoo/files/bcfg2-server
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+#
+# bcfgd - bcfg configuration daemon
+#
+#
+
+depend () {
+ need net
+}
+
+start () {
+ ebegin "Starting bcfgd"
+ start-stop-daemon --start --quiet --pidfile /var/run/bcfgd.pid \
+ --startas /usr/sbin/bcfgd.py -- --daemon=/var/run/bcfgd.pid
+ eend $? "Failed to start bcfgd"
+}
+
+stop () {
+ ebegin "Stopping bcfgd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bcfgd.pid \
+ --signal INT
+ eend $? "Failed to stop bcfgd"
+ [ -f /var/run/bcfgd.pid ] && rm -f /var/run/bcfgd.pid
+}
diff --git a/gentoo/files/digest-bcfg2-0.6.9.2 b/gentoo/files/digest-bcfg2-0.6.9.2
index e69de29bb..88923ff68 100644
--- a/gentoo/files/digest-bcfg2-0.6.9.2
+++ b/gentoo/files/digest-bcfg2-0.6.9.2
@@ -0,0 +1 @@
+MD5 1e2585a3655b12123098d721889f7f2a bcfg2-0.6.9.2.tar.gz 70814