summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSol Jerome <sol.jerome@gmail.com>2012-09-07 08:13:35 -0500
committerSol Jerome <sol.jerome@gmail.com>2012-09-07 08:14:30 -0500
commit3e9f06492b1d53edf822fa9bdacd06e2fbb146d1 (patch)
tree2e7ff2d790533c7ccded1abfed3d92582a3c339c /setup.py
parent53bfd7731bc51819bfe2b4d0ea4c7c85a0247979 (diff)
downloadbcfg2-3e9f06492b1d53edf822fa9bdacd06e2fbb146d1.tar.gz
bcfg2-3e9f06492b1d53edf822fa9bdacd06e2fbb146d1.tar.bz2
bcfg2-3e9f06492b1d53edf822fa9bdacd06e2fbb146d1.zip
setup.py: Integrate tests with setuptools
This allows you to run the testsuite by simply doing a `python setup.py test` from the project directory. Signed-off-by: Sol Jerome <sol.jerome@gmail.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6f8ac98cf..0604159f9 100755
--- a/setup.py
+++ b/setup.py
@@ -134,6 +134,8 @@ setup(cmdclass=cmdclass,
description="Bcfg2 Server",
author="Narayan Desai",
author_email="desai@mcs.anl.gov",
+ # nosetests
+ test_suite = 'nose.collector',
packages=["Bcfg2",
"Bcfg2.Client",
"Bcfg2.Client.Tools",