summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorTim Laszlo <tim.laszlo@gmail.com>2012-10-08 10:38:02 -0500
committerTim Laszlo <tim.laszlo@gmail.com>2012-10-08 10:38:02 -0500
commit44638176067df5231bf0be30801e36863391cd1f (patch)
tree6aaba73d03f9a5532047518b9a3e8ef3e63d3f9f /setup.py
parent1a3ced3f45423d79e08ca7d861e8118e8618d3b2 (diff)
downloadbcfg2-44638176067df5231bf0be30801e36863391cd1f.tar.gz
bcfg2-44638176067df5231bf0be30801e36863391cd1f.tar.bz2
bcfg2-44638176067df5231bf0be30801e36863391cd1f.zip
Reporting: Merge new reporting data
Move reporting data to a new schema Use south for django migrations Add bcfg2-report-collector daemon Conflicts: doc/development/index.txt doc/server/plugins/connectors/properties.txt doc/server/plugins/generators/packages.txt setup.py src/lib/Bcfg2/Client/Tools/SELinux.py src/lib/Bcfg2/Compat.py src/lib/Bcfg2/Encryption.py src/lib/Bcfg2/Options.py src/lib/Bcfg2/Server/Admin/Init.py src/lib/Bcfg2/Server/Admin/Reports.py src/lib/Bcfg2/Server/BuiltinCore.py src/lib/Bcfg2/Server/Core.py src/lib/Bcfg2/Server/FileMonitor/Inotify.py src/lib/Bcfg2/Server/Plugin/base.py src/lib/Bcfg2/Server/Plugin/interfaces.py src/lib/Bcfg2/Server/Plugins/Cfg/CfgEncryptedGenerator.py src/lib/Bcfg2/Server/Plugins/FileProbes.py src/lib/Bcfg2/Server/Plugins/Ohai.py src/lib/Bcfg2/Server/Plugins/Packages/Collection.py src/lib/Bcfg2/Server/Plugins/Packages/Source.py src/lib/Bcfg2/Server/Plugins/Packages/Yum.py src/lib/Bcfg2/Server/Plugins/Packages/__init__.py src/lib/Bcfg2/Server/Plugins/Probes.py src/lib/Bcfg2/Server/Plugins/Properties.py src/lib/Bcfg2/Server/Reports/backends.py src/lib/Bcfg2/Server/Reports/manage.py src/lib/Bcfg2/Server/Reports/nisauth.py src/lib/Bcfg2/settings.py src/sbin/bcfg2-crypt src/sbin/bcfg2-yum-helper testsuite/Testsrc/Testlib/TestServer/TestPlugins/TestProbes.py testsuite/Testsrc/Testlib/TestServer/TestPlugins/TestSEModules.py
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 8 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 97455ffe3..00cb1e1b5 100755
--- a/setup.py
+++ b/setup.py
@@ -140,6 +140,11 @@ setup(cmdclass=cmdclass,
"Bcfg2.Client",
"Bcfg2.Client.Tools",
"Bcfg2.Client.Tools.POSIX",
+ "Bcfg2.Reporting",
+ "Bcfg2.Reporting.Storage",
+ "Bcfg2.Reporting.Transport",
+ "Bcfg2.Reporting.migrations",
+ "Bcfg2.Reporting.templatetags",
'Bcfg2.Server',
"Bcfg2.Server.Admin",
"Bcfg2.Server.FileMonitor",
@@ -152,17 +157,14 @@ setup(cmdclass=cmdclass,
"Bcfg2.Server.Plugins.Cfg",
"Bcfg2.Server.Reports",
"Bcfg2.Server.Reports.reports",
- "Bcfg2.Server.Reports.reports.templatetags",
- "Bcfg2.Server.SchemaUpdater",
"Bcfg2.Server.Snapshots",
],
install_requires=inst_reqs,
tests_require=['mock', 'nose', 'sqlalchemy'],
package_dir={'': 'src/lib', },
- package_data={'Bcfg2.Server.Reports.reports': ['fixtures/*.xml',
- 'templates/*.html',
- 'templates/*/*.html',
- 'templates/*/*.inc']},
+ package_data={'Bcfg2.Reporting': [ 'templates/*.html',
+ 'templates/*/*.html',
+ 'templates/*/*.inc']},
scripts=glob('src/sbin/*'),
data_files=[('share/bcfg2/schemas',
glob('schemas/*.xsd')),