summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSol Jerome <sol.jerome@gmail.com>2012-09-07 13:45:52 -0500
committerSol Jerome <sol.jerome@gmail.com>2012-09-07 13:47:49 -0500
commit95728a777866c6bc5cfbcaf03313127e971fa1ea (patch)
tree7657c990577aaff467dbf92ea0b941e380f35b13 /setup.py
parent98810be2053cf3e4448b2533e0f976dfdd1e590f (diff)
downloadbcfg2-95728a777866c6bc5cfbcaf03313127e971fa1ea.tar.gz
bcfg2-95728a777866c6bc5cfbcaf03313127e971fa1ea.tar.bz2
bcfg2-95728a777866c6bc5cfbcaf03313127e971fa1ea.zip
setup.py: Add mock to tests_require for setup.py
This allows one to run the tests without having to install the dependencies separately. Signed-off-by: Sol Jerome <sol.jerome@gmail.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 0604159f9..bf70dfe0d 100755
--- a/setup.py
+++ b/setup.py
@@ -155,6 +155,7 @@ setup(cmdclass=cmdclass,
"Bcfg2.Server.Snapshots",
],
install_requires=inst_reqs,
+ tests_require=['mock'],
package_dir={'': 'src/lib', },
package_data={'Bcfg2.Server.Reports.reports': ['fixtures/*.xml',
'templates/*.html',