summaryrefslogtreecommitdiffstats
path: root/gentoo/bcfg2-1.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gentoo/bcfg2-1.1.1.ebuild')
-rw-r--r--gentoo/bcfg2-1.1.1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/gentoo/bcfg2-1.1.1.ebuild b/gentoo/bcfg2-1.1.1.ebuild
new file mode 100644
index 000000000..6b41c16ea
--- /dev/null
+++ b/gentoo/bcfg2-1.1.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+# ssl module required.
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
+inherit distutils
+
+DESCRIPTION="Bcfg2 is a configuration management tool."
+HOMEPAGE="http://trac.mcs.anl.gov/projects/bcfg2"
+
+# handle the "pre" case
+MY_P="${P/_/}"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="server"
+
+DEPEND="app-portage/gentoolkit
+ server? (
+ dev-python/lxml
+ app-admin/gam-server )"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="Bcfg2"
+
+src_install() {
+ distutils_src_install --record=PY_SERVER_LIBS --install-scripts "${EPREFIX}"/usr/sbin
+
+ # Remove files only necessary for a server installation
+ if ! use server; then
+ rm -rf "${ED}"usr/sbin/bcfg2-*
+ rm -rf "${ED}"usr/share/bcfg2
+ rm -rf "${ED}"usr/share/man/man8
+ fi
+
+ # Install a server init.d script
+ if use server; then
+ newinitd "${FILESDIR}"/bcfg2-server.rc bcfg2-server
+ fi
+
+ insinto /etc
+ doins examples/bcfg2.conf
+}
+
+pkg_postinst () {
+ distutils_pkg_postinst
+
+ if use server; then
+ einfo "If this is a new installation, you probably need to run:"
+ einfo " bcfg2-admin init"
+ fi
+}