summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexander Sulfrian <alexander@sulfrian.net>2013-06-05 19:27:03 +0200
committerAlexander Sulfrian <alexander@sulfrian.net>2013-06-05 20:04:29 +0200
commit149dcbae2d12587fb687b81e3a1a4631f04db4d7 (patch)
tree95633022329108c836363148ef95df4cadeab109 /setup.py
parentf77799678c6132f6a8db16faa2f9c72771c017f3 (diff)
downloadtools-149dcbae2d12587fb687b81e3a1a4631f04db4d7.tar.gz
tools-149dcbae2d12587fb687b81e3a1a4631f04db4d7.tar.bz2
tools-149dcbae2d12587fb687b81e3a1a4631f04db4d7.zip
hostinfo: add -V and --version to get the version0.2.0
The version is generated from the git-tags during build (setup.py) or during run time, if executed from the git repository.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5a238e4..44f74a8 100755
--- a/setup.py
+++ b/setup.py
@@ -1,9 +1,10 @@
#!/usr/bin/env python
from distutils.core import setup
+from version import *
setup(name='hostinfo-tools',
- version='0.1.0',
+ version=get_git_version(),
description='Hostinfo database interface scripts',
author='Alexander Sulfrian',
author_email='alex@spline.inf.fu-berlin.de',