summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2013-01-14 09:16:14 -0800
committerZac Medico <zmedico@gentoo.org>2013-01-14 09:16:14 -0800
commit5f56378534e08492740bdac514d3509319cd19a9 (patch)
treeea7f5d775420fa3b74dfe79b6ddae2dcfec0ae04
parent15ec6256f3156b241346d2bc25970ec44ee43d3e (diff)
downloadportage-5f56378534e08492740bdac514d3509319cd19a9.tar.gz
portage-5f56378534e08492740bdac514d3509319cd19a9.tar.bz2
portage-5f56378534e08492740bdac514d3509319cd19a9.zip
Makefile: install man/ru/*v2.2.0_alpha152
-rw-r--r--Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/Makefile b/Makefile
index f5263f362..247c05467 100644
--- a/Makefile
+++ b/Makefile
@@ -184,10 +184,16 @@ install:
cd "$(srcdir)"; \
install -m $(INSMODE) $(DOCS) "$(DESTDIR)$(docdir)"; \
\
- for x in 1 5 ; do \
- install -d -m$(DIRMODE) "$(DESTDIR)$(mandir)/man$$x"; \
- cd "$(srcdir)/man"; \
- install -m$(INSMODE) *.$$x "$(DESTDIR)$(mandir)/man$$x"; \
+ for x in "" $$(cd "$(srcdir)/man" && find -type d) ; do \
+ for y in 1 5 ; do \
+ cd "$(srcdir)/man/$$x"; \
+ files=$$(echo *.$$y); \
+ if [ -z "$$files" ] || [ "$$files" = "*.$$y" ]; then \
+ continue; \
+ fi; \
+ install -d -m$(DIRMODE) "$(DESTDIR)$(mandir)/$$x/man$$y"; \
+ install -m$(INSMODE) *.$$y "$(DESTDIR)$(mandir)/$$x/man$$y"; \
+ done; \
done; \
\
if [ -f "$(srcdir)/doc/portage.html" ] ; then \