summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2013-01-15 00:10:34 +0100
committerArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2013-01-15 00:10:34 +0100
commite803c29f893097a5a536403066dc074ad08df09c (patch)
treeaf1542bc189dc132ebb2f4382625fbf38551da2d
parent5f56378534e08492740bdac514d3509319cd19a9 (diff)
downloadportage-e803c29f893097a5a536403066dc074ad08df09c.tar.gz
portage-e803c29f893097a5a536403066dc074ad08df09c.tar.bz2
portage-e803c29f893097a5a536403066dc074ad08df09c.zip
Respect LINGUAS in 'make install'.
-rw-r--r--Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 247c05467..be2e0891b 100644
--- a/Makefile
+++ b/Makefile
@@ -34,6 +34,7 @@ BINDIR_FILES = ebuild egencache emerge emerge-webrsync \
SBINDIR_FILES = archive-conf dispatch-conf emaint \
env-update etc-update fixpackages regenworld
DOCS = ChangeLog NEWS RELEASE-NOTES
+LINGUAS ?= $(shell cd "$(srcdir)/man" && find -mindepth 1 -type d)
ifdef PYTHONPATH
PYTHONPATH := $(srcdir)/pym:$(PYTHONPATH)
@@ -184,15 +185,17 @@ install:
cd "$(srcdir)"; \
install -m $(INSMODE) $(DOCS) "$(DESTDIR)$(docdir)"; \
\
- for x in "" $$(cd "$(srcdir)/man" && find -type d) ; do \
+ for x in "" $(LINGUAS); do \
for y in 1 5 ; do \
- cd "$(srcdir)/man/$$x"; \
- files=$$(echo *.$$y); \
- if [ -z "$$files" ] || [ "$$files" = "*.$$y" ]; then \
- continue; \
+ if [ -d "$(srcdir)/man/$$x" ]; then \
+ cd "$(srcdir)/man/$$x"; \
+ files=$$(echo *.$$y); \
+ if [ -z "$$files" ] || [ "$$files" = "*.$$y" ]; then \
+ continue; \
+ fi; \
+ install -d -m$(DIRMODE) "$(DESTDIR)$(mandir)/$$x/man$$y"; \
+ install -m$(INSMODE) *.$$y "$(DESTDIR)$(mandir)/$$x/man$$y"; \
fi; \
- install -d -m$(DIRMODE) "$(DESTDIR)$(mandir)/$$x/man$$y"; \
- install -m$(INSMODE) *.$$y "$(DESTDIR)$(mandir)/$$x/man$$y"; \
done; \
done; \
\