summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-30 21:51:19 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-30 21:51:19 +0000
commit811906497dc7f81f835c30cb4b95bff398d65869 (patch)
tree4e3193e272221df22060e6dfb6b1114f85f2caeb /bin/repoman
parentaf8070e6d6550bfd854674d5211a2c0763480480 (diff)
downloadportage-811906497dc7f81f835c30cb4b95bff398d65869.tar.gz
portage-811906497dc7f81f835c30cb4b95bff398d65869.tar.bz2
portage-811906497dc7f81f835c30cb4b95bff398d65869.zip
Bug #230245 - Pass the correct directory when calling `snv list` and
`svn status` since repoman supports category-level and repo-level commits. svn path=/main/trunk/; revision=10858
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman4
1 files changed, 2 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index 51c2ae2d7..55a8a301f 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -872,7 +872,7 @@ for x in scanlist:
if vcs == "cvs":
myf=open(checkdir+"/CVS/Entries","r")
if vcs == "svn":
- myf=os.popen("svn list")
+ myf = os.popen("svn list " + checkdir)
myl=myf.readlines()
myf.close()
for l in myl:
@@ -891,7 +891,7 @@ for x in scanlist:
if l[-7:] == ".ebuild":
eadded.append(l[:-7])
if vcs == "svn":
- myf=os.popen("svn status")
+ myf = os.popen("svn status " + checkdir)
myl=myf.readlines()
myf.close()
for l in myl: