summaryrefslogtreecommitdiffstats
path: root/bin/repoman
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-10-02 16:57:45 +0000
committerZac Medico <zmedico@gentoo.org>2008-10-02 16:57:45 +0000
commitba027b7ad4b65543f025cfae9c74e791209cd51c (patch)
treea9e0e66415efa56212e46882bb3ca58fedde1574 /bin/repoman
parentb6e79bf461e793d8fdd2ff35a620305ad24b26f3 (diff)
downloadportage-ba027b7ad4b65543f025cfae9c74e791209cd51c.tar.gz
portage-ba027b7ad4b65543f025cfae9c74e791209cd51c.tar.bz2
portage-ba027b7ad4b65543f025cfae9c74e791209cd51c.zip
Fix `svn status` output parsing for compatibility with subversion-1.6. Thanks
to Arfrever for this patch. svn path=/main/trunk/; revision=11613
Diffstat (limited to 'bin/repoman')
-rwxr-xr-xbin/repoman10
1 files changed, 5 insertions, 5 deletions
diff --git a/bin/repoman b/bin/repoman
index b30f6ab29..e281284ca 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -753,8 +753,8 @@ if vcs == "cvs":
if vcs == "svn":
svnstatus = os.popen("svn status").readlines()
- mychanged = [ "./" + elem.rstrip()[7:] for elem in svnstatus if elem and elem[:1] in "MR" ]
- mynew = [ "./" + elem.rstrip()[7:] for elem in svnstatus if elem.startswith("A") ]
+ mychanged = [ "./" + elem.split()[-1:][0] for elem in svnstatus if elem and elem[:1] in "MR" ]
+ mynew = [ "./" + elem.split()[-1:][0] for elem in svnstatus if elem.startswith("A") ]
if vcs:
new_ebuilds.update(x for x in mynew if x.endswith(".ebuild"))
@@ -1711,9 +1711,9 @@ else:
if vcs == "svn":
if myautoadd:
svnstatus = os.popen("svn status").readlines()
- mychanged = [ "./" + elem.rstrip()[7:] for elem in svnstatus if elem and elem[:1] in "MR" ]
- mynew = [ "./" + elem.rstrip()[7:] for elem in svnstatus if elem.startswith("A") ]
- myremoved = [ "./" + elem.rstrip()[7:] for elem in svnstatus if elem.startswith("D") ]
+ mychanged = [ "./" + elem.split()[-1:][0] for elem in svnstatus if elem and elem[:1] in "MR" ]
+ mynew = [ "./" + elem.split()[-1:][0] for elem in svnstatus if elem.startswith("A") ]
+ myremoved = [ "./" + elem.split()[-1:][0] for elem in svnstatus if elem.startswith("D") ]
# in contrast to CVS, SVN expands nothing by default.
# bin_blobs historically
# were just there to see what files need to be checked for