summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-01-11 05:33:52 +0000
committerZac Medico <zmedico@gentoo.org>2008-01-11 05:33:52 +0000
commit4ec89e2fa8ef6a40e7258a2f1b74847f199ae154 (patch)
tree14ed3dafe1f9fd818d5dc65641eb15539c69d9f8 /bin
parentd936a954f95c325be257e423f831a08839fcb396 (diff)
downloadportage-4ec89e2fa8ef6a40e7258a2f1b74847f199ae154.tar.gz
portage-4ec89e2fa8ef6a40e7258a2f1b74847f199ae154.tar.bz2
portage-4ec89e2fa8ef6a40e7258a2f1b74847f199ae154.zip
per bug 204468, remove old check from repoman (all ebuilds in
gentoo-x86 are migrated). (trunk r9144) svn path=/main/branches/2.1.2/; revision=9168
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman26
1 files changed, 0 insertions, 26 deletions
diff --git a/bin/repoman b/bin/repoman
index b4b648271..738746e67 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -909,27 +909,6 @@ else:
#this can be problematic if xmllint changes their output
xmllint_capable=True
-
-def x11_deprecation_check(depstr):
- if depstr.find("virtual/x11") == -1:
- return False
- depsplit = depstr.split()
- ok_stack = []
- ok = False
- for token in depsplit:
- if token == "(":
- ok_stack.append(ok)
- ok = False
- elif token == ")":
- ok = ok_stack.pop()
- elif token == "||":
- ok = True
- else:
- ok = False
- if token.find("virtual/x11") != -1 and (not ok_stack or not ok_stack[-1]):
- return True
- return False
-
MISSING_QUOTES_ERROR = 'Unquoted Variable on line: %d'
NESTED_DIE_ERROR = 'Ebuild calls die in a subshell on line: %d'
REDUNDANT_CD_S_ERROR = 'Ebuild has redundant cd ${S} statement on line: %d'
@@ -1606,11 +1585,6 @@ for x in scanlist:
badlicsyntax = badlicsyntax > 0
badprovsyntax = badprovsyntax > 0
- if not baddepsyntax:
- if x11_deprecation_check(" ".join([myaux["DEPEND"], myaux["RDEPEND"], myaux["PDEPEND"]])):
- stats["usage.obsolete"] += 1
- fails["usage.obsolete"].append("%s/%s.ebuild: not migrated to modular X" % (x, y))
-
# uselist checks - global
myuse = []
default_use = []