summaryrefslogtreecommitdiffstats
path: root/bin
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2007-04-20 21:52:15 +0000
committerZac Medico <zmedico@gentoo.org>2007-04-20 21:52:15 +0000
commit5a1946a2cfa2780aa4e6563fcaa6c35d7095536e (patch)
treed64050ec890d6a14ff6100a6a323bcc29b632a5b /bin
parenta981b183da38a3a85ed3e2938b7ce5640e6ef026 (diff)
downloadportage-5a1946a2cfa2780aa4e6563fcaa6c35d7095536e.tar.gz
portage-5a1946a2cfa2780aa4e6563fcaa6c35d7095536e.tar.bz2
portage-5a1946a2cfa2780aa4e6563fcaa6c35d7095536e.zip
For bug #175344, handle a potential InvalidDependString exception when parsing PROVIDE.
svn path=/main/trunk/; revision=6421
Diffstat (limited to 'bin')
-rwxr-xr-xbin/repoman10
1 files changed, 8 insertions, 2 deletions
diff --git a/bin/repoman b/bin/repoman
index f2e520c6e..6194d1714 100755
--- a/bin/repoman
+++ b/bin/repoman
@@ -1000,8 +1000,14 @@ for x in scanlist:
#for x in myaux[allvars.index("RESTRICT")].split():
# if x.startswith("no"):
# print "Bad RESTRICT value: %s" % x
-
- myaux["PROVIDE"] = portage.dep.use_reduce(portage.dep.paren_reduce(myaux["PROVIDE"]), matchall=1)
+ try:
+ myaux["PROVIDE"] = portage.dep.use_reduce(
+ portage.dep.paren_reduce(myaux["PROVIDE"]), matchall=1)
+ except portage.exception.InvalidDependString, e:
+ stats["PROVIDE.syntax"] = stats["PROVIDE.syntax"] + 1
+ fails["PROVIDE.syntax"].append(mykey+".ebuild PROVIDE: "+str(e))
+ del e
+ continue
myaux["PROVIDE"] = " ".join(portage.flatten(myaux["PROVIDE"]))
for myprovide in myaux["PROVIDE"].split():
prov_cp = portage.dep_getkey(myprovide)