summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorZaba999 <zaba.marcin@gmail.com>2012-07-10 22:58:52 +0200
committerZaba999 <zaba.marcin@gmail.com>2012-07-10 22:58:52 +0200
commit1910219518afb26edf7329e0945b9ddba8061a08 (patch)
tree57e72fa1803ab58358cab01055d883aa2fc32e60 /CMakeLists.txt
parentdbd62c96aa351dc1c21e3392348edda2eb012e09 (diff)
downloadcolobot-1910219518afb26edf7329e0945b9ddba8061a08.tar.gz
colobot-1910219518afb26edf7329e0945b9ddba8061a08.tar.bz2
colobot-1910219518afb26edf7329e0945b9ddba8061a08.zip
Dependency on WINAPI completely removed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5ca52f8..44c0a3f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,9 +12,10 @@ find_package(SDL_image REQUIRED)
# Build with debugging symbols
set(CMAKE_BUILD_TYPE debug)
+
# Global compile flags
-set(CMAKE_CXX_FLAGS_RELEASE "-O2 -Wall")
-set(CMAKE_CXX_FLAGS_DEBUG "-w -g -O0 -Wall")
+set(CMAKE_CXX_FLAGS_RELEASE "-O2 -Wall -std=gnu++0x")
+set(CMAKE_CXX_FLAGS_DEBUG "-w -g -O0 -Wall -std=gnu++0x")
# Subdirectory with sources
add_subdirectory(src bin)