summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-06-30 10:16:52 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-06-30 10:16:52 +0200
commit9a268f553869ee59288873e059ca938d404378c4 (patch)
treec4c5cc402e007ff58477d5ea6a458695f74521a0 /CMakeLists.txt
parente37019943cb77d8c0735b330339a139430202fd8 (diff)
downloadcolobot-9a268f553869ee59288873e059ca938d404378c4.tar.gz
colobot-9a268f553869ee59288873e059ca938d404378c4.tar.bz2
colobot-9a268f553869ee59288873e059ca938d404378c4.zip
Switched back to old standard; addded -Wall
- removed -std=c++11 - added -Wall and removed most reported warnings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b825022..d0fc02e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,8 +13,8 @@ find_package(SDL_image REQUIRED)
set(CMAKE_BUILD_TYPE debug)
# Global compile flags
-set(CMAKE_CXX_FLAGS_RELEASE "-std=c++11 -O2")
-set(CMAKE_CXX_FLAGS_DEBUG "-std=c++11 -w -g -O0")
+set(CMAKE_CXX_FLAGS_RELEASE "-O2")
+set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0")
# Subdirectory with sources
add_subdirectory(src bin)