summaryrefslogtreecommitdiffstats
path: root/lib/gmock/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-12-16 13:22:58 +0100
committerPiotr Dziwinski <piotrdz@gmail.com>2012-12-16 13:22:58 +0100
commit56a170391f944f7a042b81fe7e6817a0c28fb005 (patch)
tree6a4d1adaf2a094d98852e77e7178713884a5b66a /lib/gmock/CMakeLists.txt
parent72ce040054f1ee20576094220075af4283674720 (diff)
downloadcolobot-56a170391f944f7a042b81fe7e6817a0c28fb005.tar.gz
colobot-56a170391f944f7a042b81fe7e6817a0c28fb005.tar.bz2
colobot-56a170391f944f7a042b81fe7e6817a0c28fb005.zip
Split gtest and gmock, fixed using system packages
- split the bundled gtest and gmock libraries - allowed the use of system gmock - refactoring in CMakeLists
Diffstat (limited to 'lib/gmock/CMakeLists.txt')
-rw-r--r--lib/gmock/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/gmock/CMakeLists.txt b/lib/gmock/CMakeLists.txt
new file mode 100644
index 0000000..3fec0d3
--- /dev/null
+++ b/lib/gmock/CMakeLists.txt
@@ -0,0 +1,6 @@
+cmake_minimum_required(VERSION 2.8)
+
+include_directories(. include ${GTEST_INCLUDE_DIR})
+
+# gmock-all.cc includes all other sources
+add_library(gmock STATIC src/gmock-all.cc)