summaryrefslogtreecommitdiffstats
path: root/src/common/test/CMakeLists.txt
diff options
context:
space:
mode:
authorPiotr Dziwinski <piotrdz@gmail.com>2012-09-29 12:19:00 +0200
committerPiotr Dziwinski <piotrdz@gmail.com>2012-09-29 12:19:00 +0200
commite9660c47c69327a131c4e4b15bea4bdc7937fd61 (patch)
treec7edc252258b6149ad09fcf9ba609f1d8cb92ae0 /src/common/test/CMakeLists.txt
parent677ce3960cd13cbf994311c76d75b343b22fd480 (diff)
parentdf4e3dfb6e623889757afe79fc4dfd29ae85748e (diff)
downloadcolobot-e9660c47c69327a131c4e4b15bea4bdc7937fd61.tar.gz
colobot-e9660c47c69327a131c4e4b15bea4bdc7937fd61.tar.bz2
colobot-e9660c47c69327a131c4e4b15bea4bdc7937fd61.zip
Merge branch 'dev' into dev-graphics
Diffstat (limited to 'src/common/test/CMakeLists.txt')
-rw-r--r--src/common/test/CMakeLists.txt16
1 files changed, 11 insertions, 5 deletions
diff --git a/src/common/test/CMakeLists.txt b/src/common/test/CMakeLists.txt
index a1a7a50..7936862 100644
--- a/src/common/test/CMakeLists.txt
+++ b/src/common/test/CMakeLists.txt
@@ -1,14 +1,20 @@
cmake_minimum_required(VERSION 2.8)
set(CMAKE_BUILD_TYPE debug)
-set(CMAKE_CXX_FLAGS_DEBUG "-Wall -g -O0 -std=c++11")
+set(CMAKE_CXX_FLAGS_DEBUG "-g -O0 -Wall -Wold-style-cast -std=gnu++0x")
+
+include_directories(
+.
+../..
+../../..
+${GTEST_DIR}/include
+)
-include_directories("../../")
-include_directories("../../../")
add_executable(image_test ../image.cpp image_test.cpp)
-target_link_libraries(image_test -lpng -lSDL -lSDL_image)
+target_link_libraries(image_test ${SDL_LIBRARY} ${SDLIMAGE_LIBRARY} ${PNG_LIBRARIES})
-add_executable(profile_test ../profile.cpp profile_test.cpp)
+add_executable(profile_test ../profile.cpp ../logger.cpp profile_test.cpp)
+target_link_libraries(profile_test gtest ${Boost_LIBRARIES})
add_test(profile_test ./profile_test)