summaryrefslogtreecommitdiffstats
path: root/gentoo
diff options
context:
space:
mode:
authorSol Jerome <sol.jerome@gmail.com>2010-11-16 13:55:01 -0600
committerSol Jerome <sol.jerome@gmail.com>2010-11-16 13:55:01 -0600
commit117f6d8aef51803a22af3687381d8e94ebb67730 (patch)
tree874f8b5ca630133d64237d18d6ca6df59971d1e9 /gentoo
parent26d630dd735d76e947289ca1ff1ed69ca1e465b4 (diff)
downloadbcfg2-117f6d8aef51803a22af3687381d8e94ebb67730.tar.gz
bcfg2-117f6d8aef51803a22af3687381d8e94ebb67730.tar.bz2
bcfg2-117f6d8aef51803a22af3687381d8e94ebb67730.zip
gentoo: Sync with latest ebuild from upstream
Signed-off-by: Sol Jerome <sol.jerome@gmail.com>
Diffstat (limited to 'gentoo')
-rw-r--r--gentoo/bcfg2-1.0_pre1.ebuild71
-rw-r--r--gentoo/bcfg2-1.0_pre3.ebuild55
-rw-r--r--gentoo/bcfg2-1.1.0rc1.ebuild54
-rw-r--r--gentoo/bcfg2-1.1.1.ebuild (renamed from gentoo/bcfg2-1.0_pre2.ebuild)40
4 files changed, 22 insertions, 198 deletions
diff --git a/gentoo/bcfg2-1.0_pre1.ebuild b/gentoo/bcfg2-1.0_pre1.ebuild
deleted file mode 100644
index 494588d0e..000000000
--- a/gentoo/bcfg2-1.0_pre1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-DESCRIPTION="Bcfg2 is a configuration management tool. Package includes client
-and server."
-HOMEPAGE="http://trac.mcs.anl.gov/projects/bcfg2"
-
-# handle the "pre" case
-MY_P="${P/_/}"
-SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-RESTRICT="mirror"
-
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="server"
-
-DEPEND="
- app-portage/gentoolkit
-
- || ( >=dev-lang/python-2.5
- (
- >=dev-lang/python-2.3
- || ( dev-python/elementtree dev-python/lxml )
- )
- )
- "
-
-RDEPEND="
- server? (
- dev-python/pyopenssl
- || ( app-admin/gamin app-admin/fam )
- )
- "
-
-src_compile() {
- python setup.py build
-}
-
-src_install() {
- python setup.py install \
- --root=${D} \
- --record=PY_SERVER_LIBS \
- --install-scripts /usr/sbin
-
- # Remove files only necessary for a server installation
- if ! use server; then
- rm -rf ${D}/usr/sbin/bcfg2-*
- rm -rf ${D}/usr/share/bcfg2
- rm -rf ${D}/usr/share/man/man8
- fi
-
- # Install a server init.d script
- if use server; then
- newinitd ${FILESDIR}/bcfg2-server.rc bcfg2-server
- fi
-
- insinto /etc
- doins ${S}/examples/bcfg2.conf
-}
-
-pkg_postinst () {
- depscan.sh
-}
-
-pkg_postrm () {
- depscan.sh
-}
diff --git a/gentoo/bcfg2-1.0_pre3.ebuild b/gentoo/bcfg2-1.0_pre3.ebuild
deleted file mode 100644
index 6b366dcb0..000000000
--- a/gentoo/bcfg2-1.0_pre3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit distutils
-
-DESCRIPTION="Bcfg2 is a configuration management tool."
-HOMEPAGE="http://trac.mcs.anl.gov/projects/bcfg2"
-
-# handle the "pre" case
-MY_P="${P/_/}"
-SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="1"
-KEYWORDS="~amd64 ~x86"
-IUSE="server"
-
-DEPEND=">=dev-lang/python-2.5"
-
-RDEPEND="app-portage/gentoolkit
- || ( dev-python/ssl-py26 >=dev-lang/python-2.6 )
- server? (
- dev-python/lxml
- app-admin/gam-server )"
-
-src_install() {
- distutils_src_install --record=PY_SERVER_LIBS --install-scripts /usr/sbin
-
- # Remove files only necessary for a server installation
- if ! use server; then
- rm -rf "${D}"/usr/sbin/bcfg2-*
- rm -rf "${D}"/usr/share/bcfg2
- rm -rf "${D}"/usr/share/man/man8
- fi
-
- # Install a server init.d script
- if use server; then
- newinitd "${FILESDIR}"/bcfg2-server.rc bcfg2-server
- fi
-
- insinto /etc
- doins "${S}"/examples/bcfg2.conf
-}
-
-pkg_postinst () {
- depscan.sh
- use server && einfo "If this is a new installation, you probably need to run: "
- use server && einfo " bcfg2-admin init"
-}
-
-pkg_postrm () {
- depscan.sh
-}
diff --git a/gentoo/bcfg2-1.1.0rc1.ebuild b/gentoo/bcfg2-1.1.0rc1.ebuild
deleted file mode 100644
index c482a5d70..000000000
--- a/gentoo/bcfg2-1.1.0rc1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-inherit distutils
-
-DESCRIPTION="Bcfg2 is a configuration management tool."
-HOMEPAGE="http://trac.mcs.anl.gov/projects/bcfg2"
-
-# handle the "pre" case
-MY_P="${P/_/}"
-SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="1"
-KEYWORDS="~amd64 ~x86"
-IUSE="server"
-
-DEPEND=">=dev-lang/python-2.5"
-
-RDEPEND="app-portage/gentoolkit
- >=dev-lang/python-2.6
- server? (
- dev-python/lxml
- app-admin/gam-server )"
-
-src_install() {
- distutils_src_install --record=PY_SERVER_LIBS --install-scripts /usr/sbin
-
- # Remove files only necessary for a server installation
- if ! use server; then
- rm -rf "${D}"/usr/sbin/bcfg2-*
- rm -rf "${D}"/usr/share/bcfg2
- rm -rf "${D}"/usr/share/man/man8
- fi
-
- # Install a server init.d script
- if use server; then
- newinitd "${FILESDIR}"/bcfg2-server.rc bcfg2-server
- fi
-
- insinto /etc
- doins "${S}"/examples/bcfg2.conf
-}
-
-pkg_postinst () {
- use server && einfo "If this is a new installation, you probably need to run: "
- use server && einfo " bcfg2-admin init"
-}
-
-pkg_postrm () {
- python_mod_cleanup
-}
diff --git a/gentoo/bcfg2-1.0_pre2.ebuild b/gentoo/bcfg2-1.1.1.ebuild
index dd4eab709..6b41c16ea 100644
--- a/gentoo/bcfg2-1.0_pre2.ebuild
+++ b/gentoo/bcfg2-1.1.1.ebuild
@@ -1,7 +1,13 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI="3"
+PYTHON_DEPEND="2:2.6"
+SUPPORT_PYTHON_ABIS="1"
+# ssl module required.
+RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
+
inherit distutils
DESCRIPTION="Bcfg2 is a configuration management tool."
@@ -14,26 +20,25 @@ S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
IUSE="server"
-DEPEND=">=dev-lang/python-2.5
- dev-python/m2crypto"
-
-RDEPEND="app-portage/gentoolkit
+DEPEND="app-portage/gentoolkit
server? (
dev-python/lxml
- dev-python/pyopenssl
app-admin/gam-server )"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME="Bcfg2"
src_install() {
- distutils_src_install --record=PY_SERVER_LIBS --install-scripts /usr/sbin
+ distutils_src_install --record=PY_SERVER_LIBS --install-scripts "${EPREFIX}"/usr/sbin
# Remove files only necessary for a server installation
if ! use server; then
- rm -rf "${D}"/usr/sbin/bcfg2-*
- rm -rf "${D}"/usr/share/bcfg2
- rm -rf "${D}"/usr/share/man/man8
+ rm -rf "${ED}"usr/sbin/bcfg2-*
+ rm -rf "${ED}"usr/share/bcfg2
+ rm -rf "${ED}"usr/share/man/man8
fi
# Install a server init.d script
@@ -42,15 +47,14 @@ src_install() {
fi
insinto /etc
- doins "${S}"/examples/bcfg2.conf
+ doins examples/bcfg2.conf
}
pkg_postinst () {
- depscan.sh
- use server && einfo "If this is a new installation, you probably need to run: "
- use server && einfo " bcfg2-admin init"
-}
+ distutils_pkg_postinst
-pkg_postrm () {
- depscan.sh
+ if use server; then
+ einfo "If this is a new installation, you probably need to run:"
+ einfo " bcfg2-admin init"
+ fi
}