summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSol Jerome <sol.jerome@gmail.com>2012-09-08 12:28:29 -0500
committerSol Jerome <sol.jerome@gmail.com>2012-09-08 12:28:29 -0500
commit72db9ffc5e0787e8f11353c6087245b50848f438 (patch)
tree08e6c97c7df8e807e3a66f643c95ee8804012e1f /setup.py
parent95728a777866c6bc5cfbcaf03313127e971fa1ea (diff)
downloadbcfg2-72db9ffc5e0787e8f11353c6087245b50848f438.tar.gz
bcfg2-72db9ffc5e0787e8f11353c6087245b50848f438.tar.bz2
bcfg2-72db9ffc5e0787e8f11353c6087245b50848f438.zip
setup.py: Add sqlalchemy to tests_require
This helps get us closer to a successfuly setup.py test run. Signed-off-by: Sol Jerome <sol.jerome@gmail.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index bf70dfe0d..14033be0a 100755
--- a/setup.py
+++ b/setup.py
@@ -124,9 +124,9 @@ try:
except ImportError:
pass
-inst_reqs = ["lxml", "nose"]
+inst_reqs = ['lxml']
if need_m2crypto:
- inst_reqs.append("M2Crypto")
+ inst_reqs.append('M2Crypto')
setup(cmdclass=cmdclass,
name="Bcfg2",
@@ -135,7 +135,7 @@ setup(cmdclass=cmdclass,
author="Narayan Desai",
author_email="desai@mcs.anl.gov",
# nosetests
- test_suite = 'nose.collector',
+ test_suite='nose.collector',
packages=["Bcfg2",
"Bcfg2.Client",
"Bcfg2.Client.Tools",
@@ -155,7 +155,7 @@ setup(cmdclass=cmdclass,
"Bcfg2.Server.Snapshots",
],
install_requires=inst_reqs,
- tests_require=['mock'],
+ tests_require=['mock', 'nose', 'sqlalchemy'],
package_dir={'': 'src/lib', },
package_data={'Bcfg2.Server.Reports.reports': ['fixtures/*.xml',
'templates/*.html',