summaryrefslogtreecommitdiffstats
path: root/packages/markdown/marked/Makefile
diff options
context:
space:
mode:
authorLauri Ojansivu <x@xet7.org>2019-04-20 15:18:33 +0300
committerLauri Ojansivu <x@xet7.org>2019-04-20 15:18:33 +0300
commit73e265d8fd050ae3daa67472b4465a5c49d68910 (patch)
tree677b233934a43d8f873e24c794ce289d85e3a9b7 /packages/markdown/marked/Makefile
parent6117097a93bfb11c8bd4c87a23c44a50e22ceb87 (diff)
downloadwekan-73e265d8fd050ae3daa67472b4465a5c49d68910.tar.gz
wekan-73e265d8fd050ae3daa67472b4465a5c49d68910.tar.bz2
wekan-73e265d8fd050ae3daa67472b4465a5c49d68910.zip
Include to Wekan packages directory contents, so that meteor command would build all directly.
This also simplifies build scripts. Thanks to xet7 !
Diffstat (limited to 'packages/markdown/marked/Makefile')
-rw-r--r--packages/markdown/marked/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/markdown/marked/Makefile b/packages/markdown/marked/Makefile
new file mode 100644
index 00000000..7deead54
--- /dev/null
+++ b/packages/markdown/marked/Makefile
@@ -0,0 +1,15 @@
+all:
+ @cp lib/marked.js marked.js
+ @uglifyjs --comments '/\*[^\0]+?Copyright[^\0]+?\*/' -o marked.min.js lib/marked.js
+
+clean:
+ @rm marked.js
+ @rm marked.min.js
+
+bench:
+ @node test --bench
+
+man/marked.1.txt:
+ groff -man -Tascii man/marked.1 | col -b > man/marked.1.txt
+
+.PHONY: clean all