summaryrefslogtreecommitdiffstats
path: root/packages/markdown/marked/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'packages/markdown/marked/Makefile')
-rw-r--r--packages/markdown/marked/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/markdown/marked/Makefile b/packages/markdown/marked/Makefile
new file mode 100644
index 00000000..7deead54
--- /dev/null
+++ b/packages/markdown/marked/Makefile
@@ -0,0 +1,15 @@
+all:
+ @cp lib/marked.js marked.js
+ @uglifyjs --comments '/\*[^\0]+?Copyright[^\0]+?\*/' -o marked.min.js lib/marked.js
+
+clean:
+ @rm marked.js
+ @rm marked.min.js
+
+bench:
+ @node test --bench
+
+man/marked.1.txt:
+ groff -man -Tascii man/marked.1 | col -b > man/marked.1.txt
+
+.PHONY: clean all